Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > KOReader

Notices

Reply
 
Thread Tools Search this Thread
Old 04-24-2024, 11:49 PM   #1
Maimun Ahmed
Mr. Developer
Maimun Ahmed began at the beginning.
 
Posts: 24
Karma: 10
Join Date: Feb 2024
Device: Kindle Voyage
Exclamation Error during build: DROPBEAR_SVR_PASSWORD_AUTH requires `crypt()'.

When I try to run ./kodev release kindlepw2, I get this error:
Code:
/home/maimun/KOReader/koreader-orig/koreader/base/thirdparty/dropbear/build/arm-linux-gnueabi/dropbear-prefix/src/dropbear/sysoptions.h:237:10: error: #error "DROPBEAR_SVR_PASSWORD_AUTH requires `crypt()'."
  237 |         #error "DROPBEAR_SVR_PASSWORD_AUTH requires `crypt()'."
      |          ^~~~~
make[5]: *** [Makefile:128: dbutil.o] Error 1
I am just building the original source code after doing ./kodev fetch-thirdparty and ./kodev build.

Is there anything I need to setup in my computer. Moreover, I get an error message whenever I try to:
Code:
gcc -o any_file any_file.c
without adding the flag
Code:
-lcrypt
.
Maimun Ahmed is offline   Reply With Quote
Reply

Tags
developement, koreader

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Avira putting TR/Crypt.XPACK.Gen in quarantine LMesk Calibre 5 06-11-2022 10:52 AM
Calibre final build error thyworld Calibre 2 06-28-2021 07:49 AM
TALES FROM THE CRYPT Ricky D'Angelo General Discussions 19 11-28-2016 05:09 AM
Help Needed: Kindle 3 LIMITED BUILD ERROR Recovery-Util dasmoover Kindle Developer's Corner 6 06-27-2012 09:53 AM
Science Fiction Dick, Philip K: The Crystal Crypt, v1, 19 October 2009. Patricia Kindle Books (offline) 0 10-19-2009 07:01 AM


All times are GMT -4. The time now is 07:09 PM.


MobileRead.com is a privately owned, operated and funded community.