Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Development

Notices

Reply
 
Thread Tools Search this Thread
Old 11-17-2017, 12:22 AM   #1
OSS542
Junior Member
OSS542 began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Oct 2017
Device: Nook Touch
calibre calls for QtWebKitWidgets, deprecated by Qt ?

Just for the fun of it, I tried building calibre 3.10.0, which is the latest as far as I know.
In doing so, I noticed that it called for QtWebKitWidgets. It seems that this was deprecated in Qt 5.5, and removed in Qt 5.6 if I understood correctly (a dubious assumption :-). The versions presently available from the official Qt download site are 4.8.x, 5.6.x, 5.7.x, 5.8.x and 5.9.x. The earlier versions are challenging to locate, though I managed to do so.
Is it possible to build calibre-3.10.0 with any later versions of Qt ?
OSS542 is offline   Reply With Quote
Advert
Old 11-17-2017, 02:42 AM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 32,242
Karma: 9826458
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
I am currently running calibre built against qt 5.9. And Qt webkit is now a community project. https://github.com/annulen/webkit
kovidgoyal is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigil 0.7.2 is deprecated? Gregg Bell Sigil 12 04-01-2014 02:17 PM
Deprecated Plugins BetterRed Plugins 2 03-17-2014 06:41 AM


All times are GMT -4. The time now is 01:30 PM.


MobileRead.com is a privately owned, operated and funded community.