Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 09-28-2017, 07:57 AM   #1
PERCE-NEIGE
Junior Member
PERCE-NEIGE began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Sep 2017
Device: none
Unhappy Resetting Calibre to repair crashes

Hi.

I'm a new user here, so hi everyone

I've a big problem with Calibre, using it with Linux Mint "Sonya" 64-bits.

I had no problem before trying to play a little with the Calibre-server.

I created a /etc/systemd/system/calibre-server.service.
And played a little in the terminal, with calibre commands, like start calibre-server, etc...

Doing that, I certainly didn't put the right things either in the Calibre-server etc file or in the Linux terminal, and my Calibre started to crash, so I renamed this file calibre-service.OLD

But the crashes go on. So I saved my config file .calibre -to keep my custom columns and my plugin settings- and I reinstalled Calibre, but the crashes go on. The GUI starts, and vanishes.

Calibre is the last version available in the Mint repository: Calibre 2.55.0.

How to reset it?

Thanks.

Debug info

Spoiler:

Quote:
calibre-debug -g
calibre 2.55 embedded-python: False is64bit: True
Linux-4.4.0-53-generic-x86_64-with-LinuxMint-18.2-sonya Linux ('64bit', 'ELF')
('Linux', '4.4.0-53-generic', '#74-Ubuntu SMP Fri Dec 2 15:59:10 UTC 2016')
Python 2.7.12
Linux: ('LinuxMint', '18.2', 'sonya')
DEBUG: 0.0 LubimyCzytac::__init__.py - loading translations
Successfully initialized third party plugins: Prettify Cover && FictionDB && EpubMerge && Clipboard Search && Count Pages && Search The Internet && Open With && BOL_NL && biblioNETka.pl && Martinus.sk && APNX Generator && Webscription && Recoll Full Text Search && QuarantineAndScrub && Fantastic Fiction Adults && Overdrive Link && Moly_hu && Anobii Fetcher && Public_gr && Annotations && Wiki Reader && Goodreads && Save Virtual Libraries To Column GUI && Library Codes && English Noun Frequency && Similar Stories && Favourites Menu && Find Duplicates && BOL_DE && Diaps Editing Toolbag && INMONDADORI && ADLIBRIS_SE && Save To Format && Biblionet_gr && EpubSplit && Save Virtual Libraries To Column && Copy Cover To Device && Modify ePub && ADLIBRIS_NO && Quality Check && Generate Cover && Libri_hu && User Category && Skoob && FanFicFare && Reading List && NormComment && Save Composite Custom Columns && Amazon.com Multiple Countries && Fantastic Fiction && Import List && Author Book Count Hierarchy && Author Book Count && MultiColumnSearch && Extract ISBN && Goodreads Sync && Ex Libris && Beam Ebooks && Consolidate All Library Metadata && Antikvarium_hu && LubimyCzytac && Read MP3 AudioBook metadata && View Manager && Obok DeDRM && MondoUrania && Clean Metadata && Quick Preferences && Resize Cover && Walk Search History && Barnes & Noble && Databazeknih && catawiki && ANOBII && SmartEject && Manage Series && Unplugged
Starting up...
Traceback (most recent call last):
File "/usr/lib/calibre/calibre/gui2/ui.py", line 152, in __init__
ac = self.init_iaction(action)
File "/usr/lib/calibre/calibre/gui2/ui.py", line 166, in init_iaction
ac = action.load_actual_plugin(self)
File "/usr/lib/calibre/calibre/customize/__init__.py", line 603, in load_actual_plugin
ac = getattr(importlib.import_module(mod), cls)(gui,
File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module
__import__(name)
File "/usr/lib/calibre/calibre/customize/zipplugin.py", line 179, in load_module
exec compiled in mod.__dict__
File "calibre_plugins.apnx_generator.apnxaction", line 14, in <module>
File "/usr/lib/calibre/calibre/startup.py", line 36, in load_module
raise ImportError('Importing PyQt4 is not allowed as calibre uses PyQt5')
ImportError: Importing PyQt4 is not allowed as calibre uses PyQt5
Traceback (most recent call last):
File "/usr/lib/calibre/calibre/gui2/ui.py", line 152, in __init__
ac = self.init_iaction(action)
File "/usr/lib/calibre/calibre/gui2/ui.py", line 166, in init_iaction
ac = action.load_actual_plugin(self)
File "/usr/lib/calibre/calibre/customize/__init__.py", line 603, in load_actual_plugin
ac = getattr(importlib.import_module(mod), cls)(gui,
File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module
__import__(name)
File "/usr/lib/calibre/calibre/customize/zipplugin.py", line 179, in load_module
exec compiled in mod.__dict__
File "calibre_plugins.recoll_fulltext_search.ui", line 18, in <module>
File "/usr/lib/calibre/calibre/customize/zipplugin.py", line 179, in load_module
exec compiled in mod.__dict__
File "calibre_plugins.recoll_fulltext_search.main", line 17, in <module>
File "/usr/lib/calibre/calibre/startup.py", line 36, in load_module
raise ImportError('Importing PyQt4 is not allowed as calibre uses PyQt5')
ImportError: Importing PyQt4 is not allowed as calibre uses PyQt5
Traceback (most recent call last):
File "/usr/lib/calibre/calibre/gui2/ui.py", line 152, in __init__
ac = self.init_iaction(action)
File "/usr/lib/calibre/calibre/gui2/ui.py", line 166, in init_iaction
ac = action.load_actual_plugin(self)
File "/usr/lib/calibre/calibre/customize/__init__.py", line 603, in load_actual_plugin
ac = getattr(importlib.import_module(mod), cls)(gui,
File "/usr/lib/python2.7/importlib/__init__.py", line 37, in import_module
__import__(name)
File "/usr/lib/calibre/calibre/customize/zipplugin.py", line 179, in load_module
exec compiled in mod.__dict__
File "calibre_plugins.similar_stories.action", line 12, in <module>
File "/usr/lib/calibre/calibre/startup.py", line 36, in load_module
raise ImportError('Importing PyQt4 is not allowed as calibre uses PyQt5')
ImportError: Importing PyQt4 is not allowed as calibre uses PyQt5
DEBUG: 0.0 NormComment::action.py - loading translations
DEBUG: 0.0 obok::utilities.py - loading translations
DEBUG: 0.0 obok::dialogs.py - loading translations
DEBUG: 0.0 obok::config.py - loading translations
DEBUG: 0.1 obok::action_err.py - loading translations
Loaded cached store plugin for: Amazon UK Kindle at version: 15
Loaded cached store plugin for: Nexto at version: 4
Loaded cached store plugin for: Amazon FR Kindle at version: 15
Loaded cached store plugin for: Woblink at version: 13
Loaded cached store plugin for: Smashwords at version: 5
Loaded cached store plugin for: Amazon Kindle at version: 14
Loaded cached store plugin for: Kobo at version: 7
Loaded cached store plugin for: Amazon DE Kindle at version: 15
Loaded cached store plugin for: Virtualo at version: 9
Loaded cached store plugin for: Amazon ES Kindle at version: 15
Loaded cached store plugin for: Amazon AU Kindle at version: 5
Loaded cached store plugin for: Amazon IN Kindle at version: 5
Loaded cached store plugin for: Legimi at version: 8
Loaded cached store plugin for: Google Books at version: 4
Loaded cached store plugin for: Baen Ebooks at version: 2
Loaded cached store plugin for: eBooks.com at version: 3
Loaded cached store plugin for: Ebookpoint at version: 8
Loaded cached store plugin for: OZON.ru at version: 3
Loaded cached store plugin for: Publio at version: 7
Loaded cached store plugin for: Amazon CA Kindle at version: 7
Loaded cached store plugin for: eBook.nl at version: 2
Loaded cached store plugin for: Amazon IT Kindle at version: 15
Failed to create system tray icon, your desktop environment probably does not support the StatusNotifier spec
EpubMerge: DEBUG: 2017-09-28 14:03:41,942: calibre_plugins.epubmerge.epubmerge_plugin(152): macmenuhack file_path:/home/user/.config/calibre/plugins/fanficfare_macmenuhack.txt
FFF: INFO: 2017-09-28 14:03:42,276: calibre_plugins.fanficfare_plugin.prefs(204): Attempting to read settings from predecessor--FFDL
FFF: INFO: 2017-09-28 14:03:42,276: calibre_plugins.fanficfare_plugin.prefs(209): Using default settings
FFF: DEBUG: 2017-09-28 14:03:42,306: calibre_plugins.fanficfare_plugin.fff_plugin(207): Plugin FanFicFare macmenuhack file_path:/home/user/.config/calibre/plugins/fanficfare_macmenuhack.txt
MCS has finished initialization...
DEBUG: 0.0 HttpHelper::__init__: proxy=None
SMART_DEV ( 0.00: 0.002) _attach_to_port try ip address "" on port 9090
SMART_DEV ( 1.46: 0.988) startup_on_demand listening on port 9090
SMART_DEV ( 1.46: 0.001) _attach_to_port try ip address "" on port 54982
SMART_DEV ( 1.47: 0.000) startup_on_demand broadcast socket listening on port 54982
Started up in 24.59 seconds with 5042 books
SMART_DEV ( 2.47: 1.004) run All IP addresses {'wlp2s0': [{'broadcast': '192.168.0.255', 'netmask': '255.255.255.0', 'addr': '192.168.0.24'}], 'lo': [{'peer': '127.0.0.1', 'netmask': '255.0.0.0', 'addr': '127.0.0.1'}], 'virbr0': [{'broadcast': '192.168.122.255', 'netmask': '255.255.255.0', 'addr': '192.168.122.1'}]}
user@user ~ $

Last edited by theducks; 09-28-2017 at 09:45 AM. Reason: changed <> to []
PERCE-NEIGE is offline   Reply With Quote
Old 09-28-2017, 10:04 AM   #2
DaltonST
Deviser
DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.
 
DaltonST's Avatar
 
Posts: 1,636
Karma: 256020
Join Date: Aug 2013
Location: Texas
Device: 10" Win10 Tablet w/Calibre64, CalibreSpy & Freda+
Quote:
Calibre is the last version available in the Mint repository: Calibre 2.55.0.
That is your first problem. Never install Calibre from anywhere except the official web site for Calibre, which is https://calibre-ebook.com/ . Follow the special instructions for Linux.

Afterwards, uninstall any plug-in that still requires Qt4 with no provision for Qt5. You have several. Your error messages should be reduced, leaving you with only "real" problems.


DaltonST
DaltonST is offline   Reply With Quote
Old 09-29-2017, 03:14 AM   #3
PERCE-NEIGE
Junior Member
PERCE-NEIGE began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Sep 2017
Device: none
Talking

Thank Dalton you for the reply!

I'm surprised: it's not the same Calibre from the same author in the Linux repo? I saw it's not the last version (2.55 vs 3.8), but I though it was official...

It's working!
Calibre 3 seems really improved!
It was very slow to start, now it's fast, and when I want to visualize a book, it was particularly slow to load before. I'm happy.
I uninstalled from Synaptics with the total uninstall option (including config files) and now, I didn't nothing and all my custom column and my plugins are already there!

Spoiler:

Quote:
calibre-debug -g
calibre 3.8 embedded-python: True is64bit: True
Linux-4.4.0-53-generic-x86_64-with-debian-stretch-sid Linux ('64bit', 'ELF')
('Linux', '4.4.0-53-generic', '#74-Ubuntu SMP Fri Dec 2 15:59:10 UTC 2016')
Python 2.7.12
Linux: ('debian', 'stretch/sid', '')
Interface language: fr
DEBUG: 0.0 GetFileName::__init__.py - loading translations
DEBUG: 0.0 GetFileName::__init__.py - loading translations
DEBUG: 0.0 LubimyCzytac::__init__.py - loading translations
Successfully initialized third party plugins: Barnes & Noble (1, 2, 14) && Recoll Full Text Search (1, 0, 1) && Favourites Menu (1, 0, 4) && NormComment (0, 0, 2) && Fantastic Fiction Adults (1, 0, 4) && Search The Internet (1, 7, 6) && Anobii Fetcher (1, 1, 0) && EpubMerge (2, 1, 1) && Kindle Collections (1, 7, 17) && Kobo Utilities (2, 6, 0) && Drop Search Results (1, 0, 8) && APNX Generator (1, 1, 0) && Embed Comic Metadata (1, 3, 7) && Author Book Count (2, 1, 5) && Library Codes (1, 0, 30) && Open With (1, 5, 10) && Generate Cover (1, 5, 21) && Obok DeDRM (6, 5, 4) && Martinus.sk (0, 1, 1) && Author Book Count Hierarchy (1, 1, 8) && Reading List (1, 6, 6) && Amazon.com Multiple Countries (1, 0, 0) && Media File Importer (1, 0, 20) && Moly_hu (1, 0, 4) && Manage Series (1, 2, 8) && biblioNETka.pl (1, 0, 1) && Skoob (1, 2, 1) && Webscription (1, 1, 0) && GetFileName (0, 0, 12) && Annotations (1, 6, 0) && User Category (1, 5, 3) && Kobo Books (1, 2, 1) && Biblionet_gr (1, 1, 0) && Consolidate All Library Metadata (2, 0, 32) && BOL_DE (0, 7, 5) && Quick Preferences (1, 4, 1) && EpubSplit (2, 2, 1) && Zotero Metadata Importer (1, 0, 51) && EpubCheck (0, 1, 2) && Audit Log (1, 0, 8) && MultiColumnSearch (1, 0, 71) && Resize Cover (1, 0, 2) && Unplugged (1, 0, 0) && Save Composite Custom Columns (1, 1, 0) && English Noun Frequency (1, 0, 7) && Diaps Editing Toolbag (0, 3, 5) && FictionDB (1, 0, 10) && Walk Search History (1, 3, 1) && FanFicFare (2, 17, 1) && Clean Metadata (0, 0, 6) && SmartEject (2, 0, 7) && Job Spy (1, 0, 78) && Prettify Cover 0.9.12 && Public_gr (1, 0, 0) && Similar Stories (1, 0, 58) && Hyphenate This! (0, 0, 8) && Ex Libris (1, 0, 19) && QuarantineAndScrub (3, 6, 103) && Extract ISBN (1, 4, 4) && Goodreads Sync (1, 10, 1) && Antikvarium_hu (1, 0, 1) && Save To Format (0, 0, 6) && ANOBII (0, 4, 3) && INMONDADORI (0, 2, 1) && Send by RSYNC (1, 0, 2) && Fantastic Fiction (1, 2, 0) && ADLIBRIS_SE (0, 2, 3) && Import List (1, 2, 0) && Modify ePub (1, 3, 13) && Save Virtual Libraries To Column (2, 0, 0) && Count Pages (1, 8, 0) && Quality Check (1, 9, 11) && Clipboard Search (1, 3, 1) && Copy Cover To Device (2, 0, 0) && Find Duplicates (1, 6, 3) && MondoUrania (0, 2, 1) && Overdrive Link (2, 15, 0) && catawiki (0, 0, 2) && View Manager (1, 4, 3) && Save Virtual Libraries To Column GUI (2, 2, 1) && djvumaker (1, 0, 2) && Wiki Reader (2, 1, 0) && Goodreads (1, 1, 12) && Read MP3 AudioBook metadata (1, 0, 79) && Databazeknih (1, 4, 0) && LubimyCzytac (2, 0, 25) && BOL_NL (3, 8, 16) && ADLIBRIS_NO (0, 0, 9) && Libri_hu (1, 0, 6) && Beam Ebooks (1, 0, 0) && OPML Importer (1, 0, 1)
Turning on automatic hidpi scaling
devicePixelRatio: 1.0
logicalDpi: 96.0 x 96.0
physicalDpi: 100.861627907 x 100.55257732
Using calibre Qt style: True
Starting up...
Traceback (most recent call last):
File "site-packages/calibre/gui2/ui.py", line 160, in __init__
File "site-packages/calibre/gui2/ui.py", line 174, in init_iaction
File "site-packages/calibre/customize/__init__.py", line 614, in load_actual_plugin
File "importlib/__init__.py", line 37, in import_module
File "site-packages/calibre/customize/zipplugin.py", line 183, in load_module
File "calibre_plugins.recoll_fulltext_search.ui", line 18, in <module>
File "site-packages/calibre/customize/zipplugin.py", line 183, in load_module
File "calibre_plugins.recoll_fulltext_search.main", line 17, in <module>
ImportError: No module named PyQt4.Qt
DEBUG: 0.0 NormComment::action.py - loading translations
DEBUG: 0.0 KoboUtilites::action.py - loading translations
DEBUG: 0.0 KoboUtilites::dialogs.py - loading translations
DEBUG: 0.0 KoboUtilites::action.py - loading translations
Traceback (most recent call last):
File "site-packages/calibre/gui2/ui.py", line 160, in __init__
File "site-packages/calibre/gui2/ui.py", line 174, in init_iaction
File "site-packages/calibre/customize/__init__.py", line 614, in load_actual_plugin
File "importlib/__init__.py", line 37, in import_module
File "site-packages/calibre/customize/zipplugin.py", line 183, in load_module
File "calibre_plugins.apnx_generator.apnxaction", line 14, in <module>
ImportError: No module named PyQt4.Qt
DEBUG: 0.0 obok::utilities.py - loading translations
DEBUG: 0.0 obok::dialogs.py - loading translations
DEBUG: 0.0 obok::config.py - loading translations
DEBUG: 0.0 obok::action_err.py - loading translations
DEBUG: 0.0 Annotations plugin: Error loading libiMobileDevice. This hasn't worked for a while, and is blacklisted in calibre v3.
DEBUG: 0.0 Annotations plugin: Error is: No module named idevice.libimobiledevice
Traceback (most recent call last):
File "site-packages/calibre/gui2/ui.py", line 160, in __init__
File "site-packages/calibre/gui2/ui.py", line 174, in init_iaction
File "site-packages/calibre/customize/__init__.py", line 614, in load_actual_plugin
File "importlib/__init__.py", line 37, in import_module
File "site-packages/calibre/customize/zipplugin.py", line 183, in load_module
File "calibre_plugins.similar_stories.action", line 12, in <module>
ImportError: No module named PyQt4.Qt
Traceback (most recent call last):
File "site-packages/calibre/gui2/ui.py", line 160, in __init__
File "site-packages/calibre/gui2/ui.py", line 174, in init_iaction
File "site-packages/calibre/customize/__init__.py", line 614, in load_actual_plugin
File "importlib/__init__.py", line 37, in import_module
File "site-packages/calibre/customize/zipplugin.py", line 183, in load_module
File "calibre_plugins.opml.ui", line 18, in <module>
File "site-packages/calibre/customize/zipplugin.py", line 183, in load_module
File "calibre_plugins.opml.main", line 18, in <module>
ImportError: No module named PyQt4.Qt
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
Key u'Ctrl+Shift+S' for shortcut Exact text search is already used by Send by RSYNC, ignoring
Key u'Ctrl+Shift+S' for shortcut Exact text search is already used by Send by RSYNC, ignoring
Key u'Ctrl+Shift+S' for shortcut Exact text search is already used by Send by RSYNC, ignoring
libpng warning: iCCP: known incorrect sRGB profile
Failed to create system tray icon, your desktop environment probably does not support the StatusNotifier spec https://www.freedesktop.org/wiki/Spe...sNotifierItem/
EpubMerge: DEBUG: 2017-09-29 08:51:33,989: calibre_plugins.epubmerge.epubmerge_plugin(152): macmenuhack file_path:/home/zeeshan/.config/calibre/plugins/fanficfare_macmenuhack.txt
Key u'Ctrl+Shift+S' for shortcut Exact text search is already used by Send by RSYNC, ignoring
DEBUG: 8.1 No Kobo Touch, Glo or Mini appears to be connected
DEBUG: 8.1 rebuild_menus - self.supports_ratings=None, self.supports_tiles=None
DEBUG: 8.1 KoboUtilities:set_toolbar_button_tooltip - start: text='None'
DEBUG: 8.1 device_driver_name - could not load extended driver. Exception= No module named kobotouch_extended.device.driver
DEBUG: 8.1 KoboUtilities:set_toolbar_button_tooltip - setting to text='Utilities to use with Kobo ereaders

Pilote : KoboTouch'
DEBUG: 8.1 device_driver_name - could not load extended driver. Exception= No module named kobotouch_extended.device.driver
Key u'Ctrl+Shift+S' for shortcut Exact text search is already used by Send by RSYNC, ignoring
Key u'Ctrl+Shift+S' for shortcut Exact text search is already used by Send by RSYNC, ignoring
libpng warning: iCCP: known incorrect sRGB profile
Key u'Ctrl+Shift+S' for shortcut Exact text search is already used by Send by RSYNC, ignoring
MCS has finished initialization...
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
Key u'Ctrl+Shift+S' for shortcut Exact text search is already used by Send by RSYNC, ignoring
FFF: INFO: 2017-09-29 08:51:34,141: calibre_plugins.fanficfare_plugin.prefs(204): Attempting to read settings from predecessor--FFDL
FFF: INFO: 2017-09-29 08:51:34,141: calibre_plugins.fanficfare_plugin.prefs(209): Using default settings
FFF: DEBUG: 2017-09-29 08:51:34,150: calibre_plugins.fanficfare_plugin.fff_plugin(207): Plugin FanFicFare macmenuhack file_path:/home/zeeshan/.config/calibre/plugins/fanficfare_macmenuhack.txt
Key u'Ctrl+Shift+S' for shortcut Exact text search is already used by Send by RSYNC, ignoring
Calibre, and hence Job Spy, was gracefully shut down last time? True
Last time daemon started: never
Last time daemon failed: never
Total daemon starts inception_to_date: 0
Total daemon failures inception-to-date: 0
libpng warning: iCCP: known incorrect sRGB profile
Key u'Ctrl+Shift+S' for shortcut Exact text search is already used by Send by RSYNC, ignoring
Job Spy has finished initialization...
DEBUG: 0.0 HttpHelper::__init__: proxy=None
Key u'Ctrl+Shift+S' for shortcut Exact text search is already used by Send by RSYNC, ignoring
Key u'Ctrl+Shift+S' for shortcut Exact text search is already used by Send by RSYNC, ignoring
Key u'Ctrl+Shift+S' for shortcut Exact text search is already used by Send by RSYNC, ignoring
SMART_DEV ( 0.00: 0.002) _attach_to_port try ip address "" on port 9090
SMART_DEV ( 1.51: 0.810) _startup_on_demand listening on port 9090
SMART_DEV ( 1.70: 0.001) _attach_to_port try ip address "" on port 54982
SMART_DEV ( 1.86: 0.000) _startup_on_demand broadcast socket listening on port 54982
SMART_DEV ( 3.02: 1.004) run All IP addresses {'lo': [{'netmask': '255.0.0.0', 'addr': '127.0.0.1', 'peer': '127.0.0.1'}], 'wlp2s0': [{'netmask': '255.255.255.0', 'broadcast': '192.168.0.255', 'addr': '192.168.0.24'}], 'virbr0': [{'netmask': '255.255.255.0', 'broadcast': '192.168.122.255', 'addr': '192.168.122.1'}]}
Started up in 22.87 seconds with 5042 books


Due to the fact the content server was rewritten in this version, I have a content server error I didn't had before:

Quote:
Failed to bind to 0.0.0.0 with error: No socket could be created -- (('0.0.0.0', 8080): [Errno 98] Adresse déjà utilisée). Trying to bind to the default interface: 192.168.0.24 instead
Adresse déjà utilisée: address already in use. I don't know how to change the ip.

Can I start the content server with the mate-session autostart? (Add> command: calibre-server) rather than creating again an etc .service file? It looks easier.



There is still a tray icon problem.
Quote:
Failed to create system tray icon, your desktop environment probably does not support the StatusNotifier spec
How to thank you for your help by adding reputation or karma?

Last edited by PERCE-NEIGE; 09-29-2017 at 03:16 AM.
PERCE-NEIGE is offline   Reply With Quote
Old 09-29-2017, 09:51 AM   #4
theducks
Well trained by Cats
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 24,775
Karma: 34257999
Join Date: Aug 2009
Location: The Central Coast of California
Device: K4NT(Fixed,New Bat.), Galaxy Tab A, Kobo Aura2
Many Repositories are notoriously out of date. (as you found).

A few others ,'know better' and adjust the code.

Calibre may not be optomized for a particular OS. It is a compromize, allowing it to run and APPEAR functionally the same over 3 major OS.

The standalone content server is not compatible with the GUI (Calibre). They can not be run together. You need to Stop the standalone content server to run the GUI. Why just not run the GUI Minimized?
theducks is offline   Reply With Quote
Old 09-29-2017, 10:13 AM   #5
DaltonST
Deviser
DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.DaltonST ought to be getting tired of karma fortunes by now.
 
DaltonST's Avatar
 
Posts: 1,636
Karma: 256020
Join Date: Aug 2013
Location: Texas
Device: 10" Win10 Tablet w/Calibre64, CalibreSpy & Freda+
You have installed 4 plug-ins that currently do not work with either Calibre 2 or Calibre 3. They are shown as startup errors in your debug log:

File "calibre_plugins.recoll_fulltext_search.main", line 17, in <module>
ImportError: No module named PyQt4.Qt

File "calibre_plugins.apnx_generator.apnxaction", line 14, in <module>
ImportError: No module named PyQt4.Qt

File "calibre_plugins.similar_stories.action", line 12, in <module>
ImportError: No module named PyQt4.Qt

File "calibre_plugins.opml.main", line 18, in <module>
ImportError: No module named PyQt4.Qt



DaltonST
DaltonST is offline   Reply With Quote
Reply

Tags
calibre 2.55, calibre server, command line, crash, linux mint 18.2

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calibre 2.58.0 - only install options: Change, Repair, Remove Lynx-lynx Calibre 6 06-04-2016 09:57 PM
Calibre won't open OR repair PhilK Devices 5 08-08-2015 06:12 AM
Calibre Crashes mosugs Calibre 4 08-02-2011 11:11 PM
Calibre Crashes llessieur Devices 12 03-25-2011 01:35 PM


All times are GMT -4. The time now is 06:11 AM.


MobileRead.com is a privately owned, operated and funded community.