Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Devices

Notices

Reply
 
Thread Tools Search this Thread
Old 06-20-2020, 06:39 PM   #1
22217
Junior Member
22217 began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Jun 2020
Device: Kobo Glo
[Kobo Glo] Updated firmware→Calibre:"Kobo database version unsupported"

calibre, version 4.0.0
WARNING: Failed: Kobo database version unsupported - See details

Your Kobo is running an updated firmware/database version. As calibre does not know about this updated firmware, database editing is disabled, to prevent corruption. You can still send books to your Kobo with calibre, but deleting books and managing collections is disabled. If you are willing to experiment and know how to reset your Kobo to Factory defaults, you can override this check by right clicking the device icon in calibre and selecting "Configure this device" and then the "Attempt to support newer firmware" option. Doing so may require you to perform a factory reset of your Kobo.
Device database version: 159.
Device firmware version: (4, 21, 15015)
22217 is offline   Reply With Quote
Old 06-20-2020, 06:56 PM   #2
theducks
Well trained by Cats
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 25,289
Karma: 34628613
Join Date: Aug 2009
Location: The Central Coast of California
Device: K4NT(Fixed,New Bat.), Galaxy Tab A, Kobo Aura2
You can safely tick the box'attempt to support newer firmware'

BUT You are 18 Calibre releases behind. One of the first things you should do when you get these types of errors is UPDATE Calibre and or the Your device (Kobo) drivers/plugins. Features may have been adde/updated
theducks is offline   Reply With Quote
Old 06-20-2020, 06:57 PM   #3
DNSB
Bibliophagist
DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.
 
DNSB's Avatar
 
Posts: 8,006
Karma: 35206981
Join Date: Jul 2010
Location: Vancouver
Device: Kobo Forma, Clara HD, Nexus 7 HD, iPad Pro, Tolino epos
Quote:
Originally Posted by 22217 View Post
calibre, version 4.0.0
WARNING: Failed: Kobo database version unsupported - See details

Your Kobo is running an updated firmware/database version. As calibre does not know about this updated firmware, database editing is disabled, to prevent corruption. You can still send books to your Kobo with calibre, but deleting books and managing collections is disabled. If you are willing to experiment and know how to reset your Kobo to Factory defaults, you can override this check by right clicking the device icon in calibre and selecting "Configure this device" and then the "Attempt to support newer firmware" option. Doing so may require you to perform a factory reset of your Kobo.
Device database version: 159.
Device firmware version: (4, 21, 15015)
I'd recommend that you update your version of calibre. 4.19.0 is the current version. If you don't want to update calibre, you should follow the instructions in the message you quoted and check the Attempt to support newer firmware box on the Metadata, on device &advanced tab in the KoboTouch driver configuration. See attached image.
Attached Thumbnails
Click image for larger version

Name:	attempt_to_support_newer_firmware.png
Views:	40
Size:	14.1 KB
ID:	180030  
DNSB is offline   Reply With Quote
Old 06-20-2020, 07:58 PM   #4
22217
Junior Member
22217 began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Jun 2020
Device: Kobo Glo
18 releases!? doesn't it check for updates?

new problem:
i downgraded, and launching the web browser now makes it hang really badly.

calibre, version 4.0.0
WARNING: Failed: Kobo database version unsupported - See details

Your Kobo is running an updated firmware/database version. As calibre does not know about this updated firmware, database editing is disabled, to prevent corruption. You can still send books to your Kobo with calibre, but deleting books and managing collections is disabled. If you are willing to experiment and know how to reset your Kobo to Factory defaults, you can override this check by right clicking the device icon in calibre and selecting "Configure this device" and then the "Attempt to support newer firmware" option. Doing so may require you to perform a factory reset of your Kobo.
Device database version: 159.
Device firmware version: (3, 19, 5761)
22217 is offline   Reply With Quote
Old 06-20-2020, 08:01 PM   #5
22217
Junior Member
22217 began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Jun 2020
Device: Kobo Glo
i updated calibre.

calibre, version 4.19.0
ERROR: Error: Error communicating with device

[Error 5] Access is denied: u'E:\\'

Traceback (most recent call last):
File "site-packages\calibre\gui2\device.py", line 90, in run
File "site-packages\calibre\gui2\device.py", line 618, in _delete_books
File "site-packages\calibre\devices\kobo\driver.py", line 538, in delete_books
WindowsError: [Error 5] Access is denied: u'E:\\'

Last edited by 22217; 06-20-2020 at 08:03 PM.
22217 is offline   Reply With Quote
Old 06-20-2020, 08:10 PM   #6
22217
Junior Member
22217 began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Jun 2020
Device: Kobo Glo
that error might be just when trying to delete 'kobo glo user guide.'
22217 is offline   Reply With Quote
Old 06-20-2020, 08:41 PM   #7
22217
Junior Member
22217 began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Jun 2020
Device: Kobo Glo
i updated the kobo glo back to the latest version. web browser works again.

i enabled 'attempt to support newer firmware,' and it can now send .epub's to the device.

thanks!
22217 is offline   Reply With Quote
Old 06-20-2020, 08:41 PM   #8
PeterT
Grand Sorcerer
PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.
 
PeterT's Avatar
 
Posts: 10,923
Karma: 61620223
Join Date: Nov 2007
Location: Toronto
Device: Nexus 7, Clara, Touch, Tolino EPOS
As an FYI, downgrading the Kobo firmware does NOT delete / recreate the database on the Kobo, so if the database had already been upgraded by a newer firmware the database version version number will stay at the version associated with the pre downgrade version. (Ugh.. I did not word that we'll).

That is why you still got the unsupported database message post downgrade.

In any case the simplest approach would just have been to select the driver option to ignore the unsupported database version.
PeterT is offline   Reply With Quote
Old 06-25-2020, 05:51 PM   #9
POETASTER
Junior Member
POETASTER began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Jun 2020
Device: Kobo (Aura ONE, Clara HD)
Same Problem

I am having the same problem. I have the latest version of both the plugins and Calibre...

Not sure what to do...

POETASTER is offline   Reply With Quote
Old 06-25-2020, 06:01 PM   #10
theducks
Well trained by Cats
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 25,289
Karma: 34628613
Join Date: Aug 2009
Location: The Central Coast of California
Device: K4NT(Fixed,New Bat.), Galaxy Tab A, Kobo Aura2
Quote:
Originally Posted by POETASTER View Post
I am having the same problem. I have the latest version of both the plugins and Calibre...

Not sure what to do...

did you try the Tick method mentioned in Post #3 ?

FWIW I have the latest FW on my Aura2
theducks is offline   Reply With Quote
Old 06-25-2020, 07:02 PM   #11
DNSB
Bibliophagist
DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.
 
DNSB's Avatar
 
Posts: 8,006
Karma: 35206981
Join Date: Jul 2010
Location: Vancouver
Device: Kobo Forma, Clara HD, Nexus 7 HD, iPad Pro, Tolino epos
Quote:
Originally Posted by POETASTER View Post
I am having the same problem. I have the latest version of both the plugins and Calibre...

Not sure what to do...

Calibre 4.19 does not support the Kobo database version from 4.22.15190 so, as mentioned, you will need that tick. Or you can wait until the next release of calibre which will have the updated support as the needed changes have been merged into the master branch.

Currently there are no issues with using the Attempt to support updated firmware option.
DNSB is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clara Kobo Database Version Unsupported TheArtfulDodger Kobo Reader 2 08-25-2019 12:49 PM
Kobo database version unsupported paulfiera Devices 4 01-10-2016 05:46 AM
Kobo database version unsupported? paulfiera Devices 2 08-28-2015 02:13 AM
Glo Kobo glo and calibre 1.25.0 : kobo database version not suported ? gperrot Kobo Reader 2 07-13-2014 10:24 AM
Failed: Kobo database version unsupported? Lesley2 Devices 4 09-30-2012 11:51 PM


All times are GMT -4. The time now is 02:41 PM.


MobileRead.com is a privately owned, operated and funded community.