Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Devices

Notices

Reply
 
Thread Tools Search this Thread
Old 07-20-2019, 03:52 AM   #1
fdwojo
Junior Member
fdwojo began at the beginning.
 
fdwojo's Avatar
 
Posts: 7
Karma: 10
Join Date: Jun 2012
Device: Samsung S8+ & Kindle Fire HD10
Question Calibre won't stop ignoring my phone

I saw that this topic was brought up and answered about 7 years ago. Well, I guess things must have changed in Calibre, because that advice doesn't work anymore.

Background: I have a Samsung S8+ and I *NEVER* want to use it to link with Calibre. I prefer to use DROPBOX for that purpose to keep my library (and I mean ALL my library) in the cloud and on my devices and my PC. Also, I'm using Win 10 Pro (all the latest updates) and latest version of Calibre (as of this writing, it's v3.46.0)

Having said that, I first tried to follow the advice that Kovid gave. Specifically that I should go into PREFS:PLUGINS, and disable the Android driver. And I did that. But here's the problem. The next time I go and plug in my phone again, followed by starting Calibre again, it seems to have forgotten that I have the Android driver disabled and it starts some dang JOB where it's scanning for I don't know what. And even though the first time this happened, I let it run for about 10 minutes before I realized that it was doing *something*, it never seemed to finish that 3rd job.

So far, the only way I can get this to work is for me to either disconnect my phone which is inconvenient for my needs, or I need to bring up the SAFELY REMOVE USB option and disconnect the device. Which means my question comes down to this:

Why do I have to go through all this rigmarole EVERY TIME?

When Calibre sees my phone connected, it brings up all these darn DEVICE icons wrongly assuming that I want to use Calibre to sync books back and forth between my PC and my phone. Of course, I never ever want to do that, and even if I click on the DEVICE icon, or if I click on the drop-down arrow for the DEVICE icon, none of those options allow me to disconnect Calibre from the device (my phone). And, yes, I noticed that there was an option for PREFS:IGNORED DEVICES, and when I open it, I see my Kindle Fire device in the IGNORED top box, and an "Android Device" in the bottom DISABLED box. I don't know if this is correct, but I *think* I need to somehow create an entry in the TOP box for my phone, but since it never completes whatever job it's doing, I never get a chance to make any changes to devices because Calibre keeps telling me that:

"ERROR: Cannot kill job: Cannot kill jobs that communicate with the device"

Could someone please tell me why it's even trying to connect in the first place, and further, can someone tell me how to make it stop doing this? (ie. make it IGNORE my phone?)

Thanks for any help and/or enlightenment that any of you could please provide.

Last edited by fdwojo; 07-20-2019 at 03:54 AM.
fdwojo is offline   Reply With Quote
Old 07-20-2019, 04:00 AM   #2
fdwojo
Junior Member
fdwojo began at the beginning.
 
fdwojo's Avatar
 
Posts: 7
Karma: 10
Join Date: Jun 2012
Device: Samsung S8+ & Kindle Fire HD10
Darnit! Stupid autocorrect!

For anyone who has read this far, I want to point out that I gave the title the opposite of my problem.

Sorry...
fdwojo is offline   Reply With Quote
Old 07-20-2019, 04:31 AM   #3
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 34,657
Karma: 12507830
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
The plugin you need to disable is the MTP plugin not the android plugin. And the first time you plug in a new MTP based device, calibre will ask you if you want it to connect to that device. You presumably answered yes at that time.
kovidgoyal is offline   Reply With Quote
Old 07-20-2019, 04:58 AM   #4
fdwojo
Junior Member
fdwojo began at the beginning.
 
fdwojo's Avatar
 
Posts: 7
Karma: 10
Join Date: Jun 2012
Device: Samsung S8+ & Kindle Fire HD10
Well, I don't recall ever being asked if I wanted to connect to Calibre. It's just been doing with without my say-so. Now, just to make sure I understood you, I don't disable MTP, right? I only configure it and check mark my phone in that list, right? Or did I get it backward, and I *DO* disable MTP? (sorry I'm dumb!)

Frank
fdwojo is offline   Reply With Quote
Old 07-20-2019, 05:01 AM   #5
fdwojo
Junior Member
fdwojo began at the beginning.
 
fdwojo's Avatar
 
Posts: 7
Karma: 10
Join Date: Jun 2012
Device: Samsung S8+ & Kindle Fire HD10
Okay, so I'm going to guess that configuring the MTP plugin was correct, because after I did that (and restarted Calibre), I plugged in my phone and IT"S IGNORING IT (YAY!)

Thanks Kovid!

Frank
fdwojo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to stop ignoring a device warekl Devices 3 11-18-2015 06:45 PM
Help! My Sony PRS-505 won't stop scanning. Latinandgreek Sony Reader 11 11-01-2010 05:09 PM
HELP Won't stop loading tobymax Sony Reader 5 05-18-2010 12:10 AM


All times are GMT -4. The time now is 11:15 AM.


MobileRead.com is a privately owned, operated and funded community.