Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Formats > Kindle Formats


Thread Tools Search this Thread
Old 04-21-2011, 06:54 PM   #1
Junior Member
Yammerhant began at the beginning.
Posts: 1
Karma: 10
Join Date: Jul 2010
Location: Scotland
Device: Kindle 3
Mobipocket Creator problem

I've encountered a strange problem with Mobipocket Creator - the start screen is nearly empty, as can be seen from the screenshot attached.

I've uninstalled, cleaned the registry, deleted the Mobipocket folder in Program Files restarted and installed again - same problem. I even tried downloading a fresh copy of the installer - still no change.

It was working just yesterday, and I haven't installed any other software or windows updates since then, so I'm completely baffled, and hope someone has encountered this.

PS: Running XP Professional, Service Pack 3, fully updated.

EDIT: I have fixed the problem, and here are the steps I took, in case anyone else encounters this annoying problem:

1. Backup your registry in case of problems (see

2. Start regedit

3. Goto HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Internet Settings\Zones\

4. Delete the parasite zone which appears before zone 0 (in my case it was named L).

5. Logout and Login.
Attached Thumbnails
Click image for larger version

Name:	Untitled-1.png
Views:	452
Size:	13.3 KB
ID:	70276  

Last edited by Yammerhant; 04-22-2011 at 02:01 PM. Reason: Found a solution
Yammerhant is offline   Reply With Quote
Old 04-23-2011, 04:58 AM   #2
yolbulduran began at the beginning.
Posts: 12
Karma: 24
Join Date: Apr 2011
Device: kindle 3
You made my day.
It worked, just exactly what you said.
I blame windows vista for nearly 2 weeks.
One user in another thread said create a new user account. A new user account corrects only pictures but not the functions.
yolbulduran is offline   Reply With Quote
Old 05-24-2011, 10:11 PM   #3
Robert Eriksson
Junior Member
Robert Eriksson began at the beginning.
Posts: 1
Karma: 10
Join Date: May 2011
Device: Kindle
EDIT: Did a System Restore and got to a point where Mobipocket actually used to work, now I just got some odd folders from some days ago I need to take care off and other stuff but Mobipocket is atleast up and running again.

Hey guys,

I've started having the same problem today where the screen pops up like that, simply really distorted, showing a few images and other stuff but non useable. Did the same thing as you, installed, uninstalled, installed, tried different folders (default and custom ones), different versions, different modules and cleaned registry of it a couple of times. Everything is clean, new install, same problem.

To my happiness I came across this guide, went on treasure hunt in regedit, to much dismay: No such 'parasite zone' in named path...

Been running smoothly up til now. Did move the folder containing the program before it happened though from C:/Users/Robert/Documents/Kindle Converters/Mobipocket to XXX/Documents/Kindle Related/Kindle Converters/Mobipocket. Have changed folder that way before though without issues (New computer, still rearranging stuff everyday) which only resulted in me having to update my Mobipocket desktop shortcut.

Any ideas? I'm using a Win 7 Home Premium Acer with x64 processor by the way.

Last edited by Robert Eriksson; 05-24-2011 at 11:25 PM.
Robert Eriksson is offline   Reply With Quote
Old 10-05-2012, 06:06 AM   #4
Junior Member
Andras began at the beginning.
Posts: 2
Karma: 10
Join Date: Oct 2012
Device: kindle
the same problem: no solution

I have exactly the same problem as Yammerhant had, but unfortunately for me the given solutions does not work ( I have no parasite zones in my registry, changing user doesn't help). Someone could please help me, please? Thank you.
Andras is offline   Reply With Quote
Old 10-11-2012, 05:03 AM   #5
Junior Member
Andras began at the beginning.
Posts: 2
Karma: 10
Join Date: Oct 2012
Device: kindle
Trying to solve a problem with Skype I have found the solution for the mobicreator problem!
Here it is:
Windows 32 bit

1. Run cmd.exe with administrator privileges (Start > type ‘cmd’ then
right click on cmd.exe and select Run as Administrator, then click
Continue when prompted by the elevation consent dialogue box). This
will open a command prompt in c:\windows\system32

2.Type “regsvr32 vbscript.dll” (Without The Quotes) press Enter

You should now get a message that says: “DllRegisterServer in vbscript.dll succeeded.”

3.Type “regsvr32 jscript.dll” (Without The Quotes) press Enter

You should now get a message that says: “DllRegisterServer in jscript.dll succeeded.”

Restart Your Computer
Andras is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mobipocket Creator lmorgh Reading and Management 6 06-14-2009 02:54 PM
Mobipocket Creator Help? Robotech_Master Kindle Formats 8 10-22-2008 12:42 PM
mobipocket creator Jules Kindle Formats 10 07-15-2008 11:12 PM
Creator How to use mobipocket creator? Jules Kindle Formats 10 06-16-2008 02:14 PM
Mobipocket Reader 4.8 and Mobipocket eNews Creator Mobipocket Reading and Management 1 01-29-2004 09:03 AM

All times are GMT -4. The time now is 10:42 PM. is a privately owned, operated and funded community.