View Single Post
Old 07-20-2012, 05:29 PM   #6
krakenmoth
Junior Member
krakenmoth began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Jul 2012
Device: win 7 tablet
Problem generating Catalog

Hi,
I've seen that others have had this problem but the solution wasn't shown
Here is the error log
Spoiler:
calibre, version 0.8.61
ERROR: Conversion Error: <b>Failed</b>: Generate catalogue

Generate catalogue
Sections: Recently Added
Catalog_EPUB_MOBI(): Generating epub for generic_eink in GUI environment
connected_device: 'None'
book count: 3225
opts:
authorClip: 100
catalog_title: u'Authors & Titles'
connected_kindle: False
descriptionClip: 380
exclude_book_marker: u':'
exclude_genre: u'\\[.+\\]'
exclude_tags: u'~,Catalogue'
header_note_source_field: ''
merge_comments: ':before:True'
output_profile: 'generic_eink'
read_book_marker: u'#genre:+'
search_text: None
sort_by: None
sort_descriptions_by_author: True
sync: False
thumb_width: u'1.90'
wishlist_tag: u'Wishlist'
Begin catalog source generation
DPI = 168; thumbnail dimensions: 320 x 425
Completed catalog source generation

InputFormatPlugin: HTML Input running
on C:\Users\SEALOR~1\AppData\Local\Temp\calibre_0.8.6 1_tmp_xn2scp\d9v6tu_epub_mobi_catalog\Catalog.opf
Parsing all content...
OPF contains invalid tours section
Python function terminated unexpectedly
xmlParseEntityRef: no name, line 5, column 13 (Error Code: 1)
Traceback (most recent call last):
File "site.py", line 132, in main
File "site.py", line 109, in run_entry_point
File "site-packages\calibre\utils\ipc\worker.py", line 192, in main
File "site-packages\calibre\gui2\convert\gui_conversion.py", line 68, in gui_catalog
File "site-packages\calibre\library\catalogs\epub_mobi.py", line 356, in run
File "site-packages\calibre\ebooks\conversion\plumber.py", line 979, in run
File "site-packages\calibre\customize\conversion.py", line 208, in __call__
File "site-packages\calibre\ebooks\conversion\plugins\html_in put.py", line 83, in convert
File "site-packages\calibre\ebooks\conversion\plumber.py", line 1143, in create_oebbook
File "site-packages\calibre\ebooks\oeb\reader.py", line 69, in __call__
File "site-packages\calibre\ebooks\oeb\reader.py", line 118, in _read_opf
File "lxml.etree.pyx", line 2743, in lxml.etree.fromstring (src/lxml/lxml.etree.c:52665)
File "parser.pxi", line 1573, in lxml.etree._parseMemoryDocument (src/lxml/lxml.etree.c:79932)
File "parser.pxi", line 1445, in lxml.etree._parseDoc (src/lxml/lxml.etree.c:78709)
File "parser.pxi", line 920, in lxml.etree._BaseParser._parseUnicodeDoc (src/lxml/lxml.etree.c:75083)
File "parser.pxi", line 564, in lxml.etree._ParserContext._handleParseResultDoc (src/lxml/lxml.etree.c:71739)
File "parser.pxi", line 645, in lxml.etree._handleParseResult (src/lxml/lxml.etree.c:72614)
File "parser.pxi", line 585, in lxml.etree._raiseParseError (src/lxml/lxml.etree.c:71955)
lxml.etree.XMLSyntaxError: xmlParseEntityRef: no name, line 5, column 13

I copied the library to another location but same error.
I tried removing thumbs.zip to no effect.
Clearly I have either bad data or bad fingers but I don't know where to look.
Help ? Please ?
TIA

Last edited by GRiker; 07-20-2012 at 05:36 PM. Reason: Put log into a spoiler
krakenmoth is offline   Reply With Quote