View Single Post
Old 05-28-2019, 01:45 PM   #9
R Wilcox
Junior Member
R Wilcox began at the beginning.
 
Posts: 4
Karma: 10
Join Date: May 2019
Device: Kindle Oasis 2nd Gen
I'm experiencing the same problem. I've been fruitlessly searching for a solution, or even just other people reporting exactly this specific issue rather than similar ones. This is the first I've found. Please bear with me, this is long because I've tried a lot of fixes and have a bunch of observational data on how the problem developed across two different kindles.

I was fortunate enough to receive an Oasis 2nd gen as an early Christmas present. At first everything was identical to my old kindles. I kept it in airplane mode, purchased books on my computer, and let them download in batches. Restoring old books worked the same way: queue up on PC via "manage my content".

After about 10 days of ownership it installed a software update while I was in the middle of redownloading my full library. From that point onwards books would no longer automatically download, whether a new purchase or an old item queued up. I had to go to "all" and tap each title to manually download them.

I tried everything: restart with the menu command, reboot by holding the power button for 40 seconds, factory reset, de-register and re-register, deleting the wifi network, checking for stuck indexing, disabling and re-enabling Whispersync, everything. No success. Three different software versions have come out since. I dutifully installed each (manually) and the problem persisted.

Meanwhile my trusty launch era Voyage and my mother's Paperwhite (purchased at the same time as my Oasis and on my account) still worked exactly as I'd expect. So the problem is clearly device-related rather than account-wide. As of today they're still working perfectly.

The final straw came several weeks ago when I realised I couldn't get book updates because they deliver via the same system. The Oasis also started crashing if I checked the list of indexing books. I contacted kindle support. The agent was very helpful and accepted that I'd tried everything without making me repeat the useless steps. She said that she could see a lot of failed downloads on her system so she recovered the kindle's logs and system logs and sent them on to the software team. Over a week later and they didn't get back to her. Without anything else to do she sent out a replacement kindle. We both thought the problem was a faulty OS install thanks to that initial update.

The replacement kindle arrived. It came out the box with the very latest OS version, including the read/unread filter. Everything worked perfectly. So I started to redownload my library. I've got over 2,700 books because I read like I breathe. I queued them up an author at a time on my PC, in batches of around 20-30 books at once. I waited for each batch to download before queuing another, keeping my kindle awake on my desk next to me as I worked. I took breaks to let it index, and checked periodically to see if indexing was progressing ok. At first they appeared instantly. About 200 books in they appeared after 5 minutes. Around 250 books in and only 3/4 of each batch would turn up, and invariably 5-10 minutes after being sent. Sometimes those missing titles would turn up in dribs and drabs in other batches, sometimes not. By around 300 books in I was waiting 25 minutes after clicking send for them to show up and half of the titles in each batch were missing. By around 350 books I was waiting an hour. 400, until the next day for them to show up. After that, nothing. No matter how long I wait, what I queue, where I send them from, whether I buy a new book or not, they will not turn up. It's a 32GB model and I've got 22GB free so space isn't the issue. The only way to get books to download is to toggle to "all" and tap each title. It just took me a week to download the remaining 2,000-ish books manually, complete with large amounts of time sat poking the kindle every 5 minutes to keep it awake because for some insane reason the Oasis won't index if charging and in sleep mode like the old models.

There's a new problem too: the kindle won't recognise that I own a new purchase. I picked up a book from Sunday's sale and of course it won't automatically download. So I went to manually download it, and it's not on my list. I searched for it on the kindle itself and it won't show in my owned items. On the kindle's own shop page the buy button has turned into "go to library" so it knows I own it; when I press the button I get "This title is unavailable at this time. Please try again later. If the problem persists please contact kindle support at [website address]." If I look on my PC in "manage my content" the book is listed. I've queued it and downloaded it successfully on my Voyage so again it's a device-related issue rather than account-wide. I've rebooted the Oasis, everything full of a factory reset and here I am, 3 days later, still unable to download this book onto my Oasis.

To further test things out I purchased another book on the kindle's own shop, something I never normally do. Downloaded immediately, everything's fine.

I contacted support again, got someone who clearly didn't know much and who had to keep putting me on hold for long periods to look at the same help pages I've already seen. I don't blame the agent at all because she tried her best but she wasn't equipped to help, couldn't help, and the call ended with her insisting that I do a factory reset again against my polite protests that I've already tried it and it won't help. She's going to phone back tomorrow to find out if the reset fixed things. I suppose I'll lie and say that I did another reset and it didn't help; I'm not spending another week rebuilding my library for a previously attempted suggestion. Or I could 'miss' the call and contact them again in the hopes of getting someone else.

I've got no sideloaded books. No Kindle Unlimited or library books. No documents. No audiobooks. No comics. Just years of plain old purchased from Amazon ebooks.

The Oasis clearly isn't talking to Amazon's server properly. I currently suspect the problem might lie in the device's queue on Amazon's side. Something must have jammed it up during the mass download, and probably the same on my original Oasis too. I kept asking if today's CS agent could get my queue emptied but she didn't know and wouldn't pursue it. I can't attempt it myself as the queue in "manage my content" on the website is always empty. Does anyone know if Amazon can clear a kindle's download queue?

At this point I don't know what to do. I read several books a week, easily, and my sight isn't wonderful so I rely on my kindle. My poor Voyage has been read half to death so I need this new one to work.

Misery likes company though, right? So I'm posting here. And you never know, the wall of text above might help someone figure something out.
R Wilcox is offline   Reply With Quote