View Single Post
Old 01-22-2018, 05:14 PM   #1
Doitsu
Wizard
Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.
 
Doitsu's Avatar
 
Posts: 4,907
Karma: 16234093
Join Date: Dec 2010
Device: Kindle PW2
[Plugin] SubsetFonts - Simple font subsetter

Last update: March 1, 2020
Current Version: "0.2.3"

This plugin is a simple fontTools wrapper, which'll subset all fonts in an epub.

Please note that the plugin will delete the original fonts and replace them with the subset fonts. Make sure to create a backup copy before running this plugin!

Credits: The plugin uses Alberto Pettarin's glyphIgo library to calculate the number of uninque characters in the book and the fontTools library to do the actual subsetting. The plugin icon (for Sigil 0.9.9.1 and higher) was created by BeckyEbook.

System requirements:

This plugin requires Sigil 0.9.5 or higher. If you're using an external Python interpreter, you'll also need to install the fontTools Python library.

Installation:

1. Select Manage Plugins from the Plugins menu and select Use Bundled Python, if it isn't already selected.

2. Click Add Plugin and select SubsetFonts_v0.2.3.zip. This will install the SubsetFonts plugin, which you can select via Plugins > Edit > SubsetFonts.

Troubleshooting:

By default, the plugin will check the fontTools GitHub website for updates and automatically update the fontTools package bundled with the plugin.
If the update check causes problems on your machine or if you'd rather update the embedded fontTools library yourself, change the following setting in SubsetFonts.json:

Code:
  "update_check": false,
If the update fails, visit the fontTools website, download the latest *.whl file, rename it to *.zip, unzip it and overwrite the plugin fontTools folder with the fontTools folder from the .whl file.

(Linux users may need to manually update the installed fontTool package with pip.)

License: GNU General Public License v3 (GPL-3)
Attached Files
File Type: zip SubsetFonts_v0.2.3.zip (683.3 KB, 68 views)

Last edited by Doitsu; 03-01-2020 at 04:11 AM. Reason: New version with slightly better OpenType support uploaded
Doitsu is offline   Reply With Quote