View Single Post
Old 01-08-2019, 02:47 AM   #4
kleedrac
Junior Member
kleedrac began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Jan 2019
Device: Lenovo Tab A10
I'm having a similar issue. The server is running fine but I'm trying to make a script to auto-add books in a certain directory. If I invoke the command:

calibredb add --recurse --with-library="http://127.0.0.1:8080/#calibre" --username="kleedrac" --password=</home/kleedrac/pwd> "/home/kleedrac/calibre/toadd"

it returns "-bash: /home/kleedrac/calibre/toadd/: is a directory"

If I reword it to
calibredb add --with-library="http://127.0.0.1:8080/#calibre" --username="kleedrac" --password=</home/kleedrac/pwd> --recurse "/home/kleedrac/calibre/toadd/"

it says nothing in the terminal but creates a file called --recurse in the /home/kleedrac/calibre/toadd/ folder! What am I doing wrong? The server is invoked with both --enable-local-write and --enable-auth

EDIT: Apparently I didn't read the documentation closely enough and wasn't escaping the <> characters. The command as it worked was:

calibredb add /home/kleedrac/calibre/toadd/ --recurse --with-library="http://127.0.0.1:8080/#calibre" --username="kleedrac" --password="<f:/home/kleedrac/pwd>"

A smart man learns from his mistakes - a wise man learns from other's

Last edited by kleedrac; 01-08-2019 at 03:02 AM.
kleedrac is offline   Reply With Quote