View Single Post
Old 10-24-2017, 06:34 AM   #1
Junior Member
csabeeface began at the beginning.
Posts: 2
Karma: 10
Join Date: Oct 2017
Device: Kindle 6
Exclamation PocketBook Basic 2 can't upload, software update, factory reset

Hi all,

I have a problem with a PocketBook Basic 2. The software version is: W614.4.4.1289

If i connect to a PC and i want to delete from it, it seems the data is deleted, but after restart the books is on the device.

I tried to erase the internal memory (from the software), after restart it is the same as before.

I try to factory reset, i should have to set the time and date, but nothing happens after it. The same books and everything is on the device.

I connect to internet and tried to download the new software version, the download is starting but after finishing, it said is corrupted.
I also download from internet, and copy from the pc to the pocketbook, but after restart the files is not on the device.

Anyone has any idea what can i do with it?
csabeeface is offline   Reply With Quote