View Single Post
Old 11-19-2017, 04:03 AM   #1
tempura
Connoisseur
tempura knows more than wikipediatempura knows more than wikipediatempura knows more than wikipediatempura knows more than wikipediatempura knows more than wikipediatempura knows more than wikipediatempura knows more than wikipediatempura knows more than wikipediatempura knows more than wikipediatempura knows more than wikipediatempura knows more than wikipedia
 
Posts: 71
Karma: 47102
Join Date: Dec 2013
Location: Outside the Universe
Device: Kindle PW3
Calibre and Qt5/GTK theming issues

I'm not sure if this is a Calibre issue or maybe a dependency issue. I recently upgraded to XUbuntu 17.10 which uses Qt 5.9. I have set the CALIBRE_USE_SYSTEM_THEME variable for calibre to use the Gtk/XFCE theme which in my case arc-theme. Note, all my other Qt5 applications including Qt5 Designer, work correctly while using the GTK theme.

A pure binary install from the script as provided on the website here: https://calibre-ebook.com/download_linux doesn't work. The theme is completely broken and there are parts of the menus which I can't access. I initially got this error on Calibre 3.0, and then I uninstalled that, and installed Calibre 3.12, both giving the same error on the system as:
Code:
QGtkStyle could not resolve GTK. Make sure you have installed the proper libraries.
Though, I tried a binary install from the Ubuntu repos for Calibre 3.7.0 which works perfectly fine, and adheres to the environment variable to use my GTK theme.

I hope this issue gets fixed sometime.

tempura

Last edited by tempura; 11-19-2017 at 04:08 AM.
tempura is offline   Reply With Quote