View Single Post
Old 12-19-2012, 04:45 PM   #8
Junior Member
Struikrover began at the beginning.
Posts: 3
Karma: 10
Join Date: Dec 2012
Device: Nexus 7
Originally Posted by chaley View Post
@Struikrover: I don't know how one enters parameters when starting tasks, so can't help there.

I think that the content server opens the db read-only, but I wouldn't guarantee that.

The reason that the admin account sees your library and the other account doesn't is probably differences in the calibre configuration between the two users. In addition to a lot of other things such as plugins and options, calibre keeps the path to the last library opened. You should have the "standard user" reference the same config folder as the "admin user", either directly or by copying the config. To find the config, start the calibre gui as admin, go to preferences -> misc and select "Open the calibre configuration directory".

My guess is that copying the config is the best option, as it will avoid all the cross-user permission problems.

One way you can get this set up is to login as the standard user, start the calibre gui, then navigate to the library folder (Switch Library). This process should record that library in the user's config. While you are there you might want to set the other content server options so you can avoid the apparently difficult setting of command-line options.
Cheers Chaley...Both Calibre instances are vanilla so to say. Started up once and directed to my library (which is what it opens at default now on start-up), so it should be set in the config properly. I redid it just to be sure but no luck. I then did a rough copy entire config folder from the admin account to my User account - Which made the whole server not run at all any more

Then I tried assigning write privileges to the standard user for the OS drive. It didn't like that at all =) But its not all bad. I solved the problem in the end by changing the account type of the Standard User to Administrator, but restricting the privileges of this User to read-only on all external drives. I can't imagine it'll hurt as it is a bare-program-bones machine, behind a hard- and soft firewall, and my external drives remain protected under this account.

Once changed the "Standard User who is Now Administrator" library showed up immediately, as like like magic. Not really what I desired but it'll do...Its worthwhile adding here that even that way but while having my library on an external drive (with restricted read-only privs) it throws a major fit (long-winded error message telling me calibre can only open the db as read-only). So I had to move the library to my C drive (which with admin now has write access) to make it function properly. So in a nutshell, I suspect that even with the stand-alone server serving a backup copy of my library (one that will not undergo any editing by me) it still requires write access to the drive regardless, and without write-access it automatically defaults to its empty library. Must be by design, perhaps the authors can confirm this?

Either way, an interesting session of problem solving , and many thanks for your help trying to trace the problem. I probably over described the problem-solving but hopefully it'll be of use to the next guy....

Anyhows have a good Holidays,
Many Cheers,
Struikrover is offline   Reply With Quote