Thread: Possible bug?
View Single Post
Old 09-15-2021, 12:26 PM   #97
BeckyEbook
Evangelist
BeckyEbook ought to be getting tired of karma fortunes by now.BeckyEbook ought to be getting tired of karma fortunes by now.BeckyEbook ought to be getting tired of karma fortunes by now.BeckyEbook ought to be getting tired of karma fortunes by now.BeckyEbook ought to be getting tired of karma fortunes by now.BeckyEbook ought to be getting tired of karma fortunes by now.BeckyEbook ought to be getting tired of karma fortunes by now.BeckyEbook ought to be getting tired of karma fortunes by now.BeckyEbook ought to be getting tired of karma fortunes by now.BeckyEbook ought to be getting tired of karma fortunes by now.BeckyEbook ought to be getting tired of karma fortunes by now.
 
BeckyEbook's Avatar
 
Posts: 466
Karma: 1497025
Join Date: Jan 2017
Location: Poland
Device: Kindle (Key3, PW2, PW3), Nook (ST, GLP), Kobo Touch, Tolino Vision 2
DiapDealer: This is the purpose of properly detecting the AltGr key so that it can still be used without triggering Sigil shortcuts.

Users of international keyboards were disadvantaged in such a way that Sigil's hotkeys overwritten characters that are obtained from AltGr. For example, in the default layout of the German language, to get the @ sign press AltGr+q. If this shortcut had been "seized" by Sigil, the user would not be able to type "@". After enabling the checkbox and restarting it will be possible.

As for the weird characters in sigil.ini, it's always been the case, but users should not select conflicting keyboard shortcuts.

I have already mentioned in this thread that I personally do not like it, because after pressing Ctrl+Alt+E on my Polish keyboard layout, I would prefer to see just such a notation, and I see Ctrl+Alt+Ę and in sigil.ini it is written as Ctrl+Alt+\x118.
In the German layout in the Shortcuts window, we will see Ctrl+Alt+, and in sigil.ini it will be Ctrl+Alt+\x20ac

Such shortcuts are completely useless because they don't work. If there was [input box "Shortcuts"], however, Ctrl+Alt+E appeared, it would all work on the Polish[*] system, German[**], and English.
[*] AltGr+E=Ę (or rather ę, because Shortcuts displays uppercase, but normally it would be a diacritic in a minuscule)
Ctrl+left Alt+E = keyboard shortcut assigned in Sigil

[**] AltGr+E=
Ctrl+left Alt+E = keyboard shortcut assigned in Sigil

Maybe I think otherwise, but I have the impression that for standard keyboards it would not matter because AltGr is not used there, but for international keyboards layouts it would be concrete progress and no records /xNNN in sigil.ini

But it may not be possible to do it, because since in the current thread the problem was related to the Shift key (and I have the impression that it has been resolved) then this problem is quite different.
BeckyEbook is online now   Reply With Quote