View Single Post
Old 11-24-2013, 07:43 AM   #6
Nick_1964
Bookworm
Nick_1964 ought to be getting tired of karma fortunes by now.Nick_1964 ought to be getting tired of karma fortunes by now.Nick_1964 ought to be getting tired of karma fortunes by now.Nick_1964 ought to be getting tired of karma fortunes by now.Nick_1964 ought to be getting tired of karma fortunes by now.Nick_1964 ought to be getting tired of karma fortunes by now.Nick_1964 ought to be getting tired of karma fortunes by now.Nick_1964 ought to be getting tired of karma fortunes by now.Nick_1964 ought to be getting tired of karma fortunes by now.Nick_1964 ought to be getting tired of karma fortunes by now.Nick_1964 ought to be getting tired of karma fortunes by now.
 
Nick_1964's Avatar
 
Posts: 975
Karma: 768585
Join Date: Aug 2010
Location: Netherlands
Device: Sony prs-650, Kobo Glo HD (2x), Kobo Glo
Quote:
Originally Posted by DoctorOhh View Post
Was this a book you had previously converted? If so you need to change the settings when you are converting. Changing the global settings won't effect a book previously converted you have to change the individual setting.

More info here.
Nope, this was the original book on the first picture, so no blank line, and on the second there was a blank line after conversion with both options turned off.

The first line started with:
<p class="noindent">Simon staarde verslagen naar de voordeur van zijn huis.</p>
Second line started with:
<p class="indent">Hij had nooit een ander thuis gekend. Dit was de plek waar zijn ouders hem naartoe hadden gebracht toen hij... and so on </p>

You can see in picture 1, there is no blank line in the original...
With both options turned off calibre inserts a blank line every time when a <p class="ident"> is in the html file ( at every paragraph ) where it is not in the original.

At the end I managed it with Sigil.
I restored the original epub and search for a place there have to be an original blank line.
Every line with <p class="noindentt"> has a blank line in the original not converted book.
I changed the line <p class="noindentt"> into 2 lines:
<p class="indent"><br /></p> ( adding an extra blank line )
<p class="noindentt">
This results in 2 blank lines where in the original was only once.
Saved it.
Then start the conversion again from the modified epub, but now the option: remove spacing between paragraps ticked on.
There are no inserted blank lines anymore inserted at the <p class="ident"> (or they are removed) And because of the <br /> between it there is only one blanc line where it supposed to be.

The behaviour during conversion looks like it doesn't matter of the option: Insert blank line between paragraps is on or off, calibre is simply adding a blank line at every paragrap at the conversion regardingless the unticked option, I can correct that by putting the option remove spacing between paragraps on, but then all the original blank lines are removed to.
In order to prevent that, I put an extra <br /> before the original blank line, convert it with removing spacing between paragraps on and then there are no blank lines at the <p class="ident"> inserted and the original blank lines are still there.

I hope you understand what I mean, it doesn't matter if the : insert blank line between paragraps is on or off, It just add a blank line at every paragraph.

Last edited by Nick_1964; 11-24-2013 at 08:29 AM.
Nick_1964 is offline   Reply With Quote