View Single Post
Old 05-18-2017, 04:21 AM   #1
GeoffR
Wizard
GeoffR ought to be getting tired of karma fortunes by now.GeoffR ought to be getting tired of karma fortunes by now.GeoffR ought to be getting tired of karma fortunes by now.GeoffR ought to be getting tired of karma fortunes by now.GeoffR ought to be getting tired of karma fortunes by now.GeoffR ought to be getting tired of karma fortunes by now.GeoffR ought to be getting tired of karma fortunes by now.GeoffR ought to be getting tired of karma fortunes by now.GeoffR ought to be getting tired of karma fortunes by now.GeoffR ought to be getting tired of karma fortunes by now.GeoffR ought to be getting tired of karma fortunes by now.
 
GeoffR's Avatar
 
Posts: 3,666
Karma: 17448207
Join Date: Nov 2012
Location: New Ulster
Device: Kobo Glo
Instructions for patching firmware 4.4.9344 and 4.4.9349

Mark 6 devices BEWARE: There are two versions of the Mark 6 firmware: 4.4.9344 and 4.4.9349. DON'T sideload the 4.4.9344 version to the Aura One, it results in a black screen and requires some effort to fix (see this post.)

* 4.4.9344 (6f700792a0, 16 May 2017):
84,642,940 bytes, MD5SUM 545969e53732d1abb904d7acf4175922 kobo-update-4.4.9344.zip

* 4.4.9349 (6f700792a0, 17 May 2017):
84,648,827 bytes, MD5SUM: b0208d75e861176f504df0a1ce2ddbf2 AuraONE_kobo-update-4.4.9349.zip

To complicate matters, the link to Mark 6 version 4.4.9344 might actually result in version 4.4.9349 being downloaded, but with the filename of the 4.4.9344 version. So don't rely on the filename, check the actual file size of the download with the information above to see which version was actually downloaded.

These patches work exactly the same for both versions 4.4.9344 and 4.4.9349, just make sure to use the same firmware version for patching that your device is already running.


See the New firmware release - 4.4.9344 discussion thread for information about what has changed in this firmware version.

See the Index to the Metazoa firmware patches thread for a description of what some of these patches do.


Before starting:

1. Make sure your Kobo ereader is already running firmware version 4.4.9344 (6f700792a0) or 4.4.9349 (6f700792a0). If not, then you need to upgrade before applying this patch.

2. Check that your battery is well charged.


Patching from Windows, Linux (i386/x86_64), or Mac (OS X 10.8-10.9, i386/x86_64):

1. Download and extract patch_kobo_4049344.zip (attached).

2. Download the Kobo firmware archive version 4.4.9344 (or 4.4.9349) for your device (See this thread) and copy it into the 4.4.9344_source/ subdirectory. (Don't unzip the firmware.)

2a. (Only necessary for Linux/Mac): If the downloaded filename was AuraONE_kobo-update-4.4.9349.zip, rename it to kobo-update-4.4.9344.zip.

3. Read and edit all the *.patch files in the 4.4.9344_source/ subdirectory in order to: choose which patches to enable (patch_enable=`yes`) or disable (patch_enable=`no`); and to change some of the replacement values to suit your device and preferences.

4. In Windows run 4.4.9344.bat (double-click); For Linux/Mac run 4.4.9344.sh (double-click, or right-click + run, or execute ./4.4.9344.sh from the command line.)

5. If there were no errors, a new 4.4.9344_target/ subdirectory will be created. Copy the KoboRoot.tgz from this subdirectory to the .kobo directory on your ereader.

6. Safely eject and unplug the device, which will then update and restart.


To return your ereader to its original unpatched state:

1. Edit all the 4.4.9344_source/*.patch files to disable all patches (set patch_enable = `no` for every patch).

2. Repeat steps 4-6 of the procedure above.


Note that the following patches are enabled by default:

In librmsdk.so.1.0.0.patch:
`Fix page breaks bug`
`Default ePub monospace font (Courier)`

In libnickel.so.1.0.0.patch:
`Custom left & right margins`
`Custom page refresh options`
`Fix three KePub fullScreenReading bugs`
Attached Files
File Type: zip patch_kobo_4049344.zip (506.0 KB, 1384 views)

Last edited by GeoffR; 05-20-2017 at 11:04 PM. Reason: Edited instruction 2a. to rename firmware file, only necessary for Linux/Mac.
GeoffR is offline   Reply With Quote