View Single Post
Old 11-16-2020, 09:07 AM   #40
theamazingjmo
Junior Member
theamazingjmo began at the beginning.
 
theamazingjmo's Avatar
 
Posts: 6
Karma: 10
Join Date: Sep 2014
Location: Ohio
Device: Paperwhite 2
Exclamation

I can't install the plugin, which is weird because it hasn't been updated since the last time I uninstalled it. Perhaps a conflict with another plugin?

Code:
calibre, version 5.5.0
ERROR: Install plugin failed: A problem occurred while installing this plugin. This plugin will now be uninstalled. Please post the error message in details below into the forum thread for this plugin and restart calibre.

Traceback (most recent call last):
  File "calibre\gui2\dialogs\plugin_updater.py", line 731, in _install_clicked
  File "calibre\customize\ui.py", line 472, in add_plugin
  File "calibre\customize\ui.py", line 61, in load_plugin
  File "calibre\customize\zipplugin.py", line 293, in load
  File "importlib\__init__.py", line 127, in import_module
  File "<frozen importlib._bootstrap>", line 1014, in _gcd_import
  File "<frozen importlib._bootstrap>", line 991, in _find_and_load
  File "<frozen importlib._bootstrap>", line 975, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 671, in _load_unlocked
  File "calibre\customize\zipplugin.py", line 185, in exec_module
  File "calibre\customize\zipplugin.py", line 181, in get_code
  File "calibre_plugins.wikidata.__init__", line 348
    print 'matches=',matches
          ^
SyntaxError: Missing parentheses in call to 'print'. Did you mean print('matches=',matches)?
theamazingjmo is offline   Reply With Quote