View Single Post
Old 05-01-2021, 04:08 AM   #13
dewd
Member
dewd began at the beginning.
 
Posts: 18
Karma: 10
Join Date: Nov 2017
Device: none
Quote:
Originally Posted by kovidgoyal View Post
Sadly there is no magic bullet. First remove the plugins sub directory from the config directory and see if that works, if not then try removing the files gui.py.json and gui.json and dynamic.pickle.json
Removing the plugins directory didn't work. Removing those three json files did, and I wondered if removing one at a time might work, so I replaced them and removed the first - gui.py.json - and that allowed Calibre to open with almost everything back the way it was. The only change to my previous set-up that I can see* is that the book details pane showed up on the right rather than the bottom and that's an easy fix.

*There might well be other changes that I'll come across as I work - it's only been five minutes! - but all the things that would have taken a long time to re-do - plugins and their configurations, general preferences, conversion options, toolbars, etc - seem to be back in place as they were before.

If you've any ideas about what might have caused the problem to happen (and thus what I or others might need to be cautious about in future), I'd be happy to hear them. But even if not, I want to express that I'm hugely grateful for your help here (on this thread and on the forums overall and more generally as the developer). I would not have been able to work through this on my own, and google wasn't really helping - and I use Calibre a *lot*, so, again, thank you!
dewd is offline   Reply With Quote