View Single Post
Old 01-04-2021, 05:37 PM   #6
Junior Member
ioancr began at the beginning.
Posts: 2
Karma: 10
Join Date: Jan 2021
Device: Likebook Mars T80D
Linux upgrade successfully done for Likebook Mars T80D.

It was not straightforward for me though. After the first failed attempt, my device would never get past the black screen. Such a despair.

But looking back now, the way how I got it working and the results, I think the new version is worth every single sigh and perhaps it's the right time to share my experience.

My host machine is a Manjaro Linux. Had to install Virtualbox and load Windows 8.1 to have the upgrade requisites as per instructions.

I couldn't get flashing according the Boyue instructions, the (otherwise working) device couldn't pass "Check chip control". I've tried various DriverAssistant packages (4.5 through 4.8), or newer AndroidTool executables. Nothing.

BRICK: <<Disclaimer: Anything you do to your device is your responsibility!>> I've switched to Linux solutions at this point. Found the Rockchip Linux Upgrade Tool. It was rather easy to flash the 8.1 firmware, everything went ok in the logs. But my device would not restart afterwards, after a brief starting logo (the bridge picture), it switched to a black screen with a white circle and a message "erasing" that left to black screen and unresponsive device. The worst thing was that the Linux Upgrade Tool couldn't "see" a compatible device anymore. The Linux explorer read it as "rk33xx" device. What a shock.

FIRST SIGNS OF LIFE: I've unplugged USB from PC and connected it to the wall charger and ... Surprise! The boot logo page appeared out of nowhere and stayed with one dot still. Obviously the reader wasn't dead. It was time to move forward and experiment.

RECOVERY: I was able to get to the Recovery Menu. However every attempt to flash an "" through it unfortunately didn't work for me. I've tried external SD card, and even an OTG USB (though it never worked before nor seemed supposed to). ADB and Fastboot couldn't access the device as it was "locked".

FOUND ONE ADB DEVICE. In Windows virtual machine's Android Tool the black screen reader was identified as "Found One ADB Device". It was rather useless, yet relieving to know that a dedicated tool was still able to detect its device. Enough to keep moving forward.

LOADER HARD KEY COMBINATION: Soon I found out that Android Tool would load my device as "Loader" - that was a good news and the right way to go. In Linux it's a bit complicated to stand by USB port switching back and forth between host and guest, especially in delicate circumstances like flashing a device. I had to keep an eye on the Virtualbox's USB window for any ongoing issue, as the bricked device would easily disconnect whenever its status changes. It could pass from "rockchip" to "unknown device 2207:3300(100)" and so on, everytime loosing the connection.

BERNADO MOD: Luckily, I found hints in this forum pointing to use of a mod of Android Tool: RK_Android_Tool_2.3.9_bernado_mod. I gave it a try. It was the first time the flashing would ever progress within Windows environment for me. However "Device reset success" didn't prove so in practice: my Likebook stayed black. Things I've experimented with where "Erase Flash" before "Upgrade" and even a "Lower Format" in the Linux Tool - both useless in my case.

FINALLY SUCCESSFUL ATTEMPT: I've soon discovered that along with the modded Android Tool there is also a Bernado mod of the Device Assistant with drivers. One has to uninstall any previous drivers first (just press "Uninstall" before installing them). Unfortunately the new drivers didn't change anything in the only tool I've relied on (as of my expectations). Together with the fact that the default "Download list" is slightly different compared to the Boyue's AndroidTool (the first two components are not selected, I'm not sure of it's relevance though) incited me to give the last one another try. Odd enough, this was the first time it would progress. The firmware flashing eventually succedded as with modded tool BUT this time the Likebook turned on and loaded just normally!

CONCLUSION: I'm still not sure what exactly restored my device, nor am I willing to reproduce anything in order to find it out. Perhaps it's in the specific details, or it's just a hazard. Anyway, my Likebook has a new life now and that is what matters.

P.S. Credits go to this Forum and to the developers of the cited tools.
ioancr is offline   Reply With Quote