View Single Post
Old 02-12-2016, 09:45 AM   #1
callahan09
Junior Member
callahan09 began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Nov 2014
Device: Samsung Galaxy Note 3 - Moon Reader+ App
Version num doesn't match d/l? & Error when clicking Add Books

So this morning I downloaded & installed version 2.51.0 when the program prompted that there is an update.

Then I clicked AddBooks and got THIS error:

Quote:
ZipImportError: can't find module win32com
So I uninstalled the program entirely and re-downloaded it and installed it.

NOW, I downloaded by clicking "download calibre" on this page:
http://calibre-ebook.com/download_windows

It says it should be version 2.51.0.

But when I open the program and click Preferences, it actually shows version 2.43.0? What's up with that?

And while I'm not getting the same error as before, when I click Add Books, I still get an error:

Quote:
IOError:zipimport: can not open file C:\Program Files\Calibre2\pylib.zip

calibre, version 2.43.0
ERROR: Unhandled exception: <b>IOError</b>:zipimport: can not open file C:\Program Files\Calibre2\pylib.zip

Traceback (most recent call last):
File "site-packages\calibre\gui2\actions\add.py", line 424, in add_books
File "site-packages\calibre\gui2\__init__.py", line 761, in choose_files
File "site-packages\calibre\gui2\__init__.py", line 672, in __init__
File "site-packages\calibre\utils\filenames.py", line 508, in expanduser
File "site.py", line 50, in load_module
IOError: zipimport: can not open file C:\Program Files\Calibre2\pylib.zip
What can I do about this? Why is it saying I installed version 2.43.0 when the download site says the current version is 2.51.0? Please help! Thanks in advance.

EDIT: UPDATE: I have tried uninstalling & reinstalling numerous times now. I even went to the download past versions page and downloaded 2.51.0 64-bit from there (I have 64-bit Windows 10 home edition OS). It still says version 2.43.0 in the program and actually gives me the win32com error again. I then downloaded an older version, 2.50.0 64-bit, and it too is giving the same error and says version 2.43.0. I'm tempted to try downloading version 2.43.0 and see if that works! For all I know, that might have been the last version I had installed before trying to update it this morning. I can't be sure, but it was probably back around November the last time I updated the program.

What's going on here???

EDIT 2: I found this post:

https://bugs.launchpad.net/calibre/+bug/907058

I added the folder to my Windows Defender exclusions list, uninstalled & reinstalled again, and all the same problems are still there.

EDIT 3: I went ahead and tried installing version 2.43.0. THIS version works. I've added the books I wanted to add. I'm not going to bother trying to update the software again until I hear a response here that could explain why this is happening and how I can get the updated versions to work. So for now, I'm sticking with version 2.43.0, and hopefully the issue I'm having does get figured out sometime.

Last edited by callahan09; 02-12-2016 at 10:22 AM.
callahan09 is offline   Reply With Quote