Thread: Development Terminal Emulator oddity
View Single Post
Old 04-27-2011, 12:01 PM   #1
Edge User
Terminal Emulator oddity

I decided to reward myself for two smoke-free weeks with an hour of playing with my new Pocket Edge (running Ermine) this morning. As I'm a sort of linux-y geek, I started by browsing through the file system using the Terminal Emulator (Dev Tools -> Terminal Emulator) with an eye toward entering 'busybox ls -alR > /MEDIA/USB0/some-file-name" to make a full file system listing that I could transfer to my PC.

It took me a while to find the "<", "|", and ">" keys on the soft keyboard, but eventually I did. What surprised me was that I couldn't manage to input any digits at all. The digits worked fine in Notepad, so it seems to be a Terminal Emulator "feature."

I next tried a USB keyboard. Most of its keys worked as expected, and entering digits into Terminal Emulator worked fine. Those pesky "<" and ">" characters were not on top of the ',' and '.' keys -- they've moved to ALT-B and ALT-N respectively. Surprisingly, the HOME key took me to the home screen and both the END and F4 keys rotated the screen clockwise (skipping the upside-down orientation) with each press. The F1 key gave me the application menu and the F3 key took me to the Contacts app.

So ... I can type the command I want with a USB keyboard, but would have to disconnect it and shove in a USB drive really fast if I want it to work . . .

Thus I have a question for you all: Can anybody get numbers "typed" on the soft keyboard accepted by Terminal Emulator? If so, are you using a big Edge? a Pocket? Running Ermine? Dingo? If not, do you care?

Thanks for taking the time to check.