View Single Post
Old 05-05-2021, 02:41 PM   #571
capink
Evangelist
capink knows more than wikipediacapink knows more than wikipediacapink knows more than wikipediacapink knows more than wikipediacapink knows more than wikipediacapink knows more than wikipediacapink knows more than wikipediacapink knows more than wikipediacapink knows more than wikipediacapink knows more than wikipediacapink knows more than wikipedia
 
Posts: 499
Karma: 47410
Join Date: Aug 2015
Device: Kindle
Quote:
Originally Posted by SoccerDad91016 View Post
Updated the Action Chains plugin to version 1.8.4 and now Calibre will not start. I get the startup banner, then the main window flashes briefly and closes. I don't see any tasks in taskmanager either.

When I run Calibre in Debug (calibre-debug -g 1>> log.txt 2>&1), I get the following error in the log file...

Traceback (most recent call last):
File "calibre_plugins.action_chains.events.base", line 49, in run
File "calibre_plugins.action_chains.events.event_tools" , line 43, in __init__
KeyError: 'event_members'


Running Calibre v5.17 64-bit on Windows 10

Was working fine prior to the latest update
I uploaded a new version that should fix this problem. You can get it directly from the first post or wait until calibre announces the update (will take calibre nearly an hour from now). Please report back on how it works for you.

This problem happens when you add an event with no chains attached to it. The problem was always there and not related to the latest release.
capink is offline   Reply With Quote