View Single Post
Old 03-08-2020, 06:56 PM   #23
Junior Member
gandalfthewite began at the beginning.
Posts: 4
Karma: 10
Join Date: Mar 2020
Device: Sony PRS-T1
My PRS-T1 reader just crapped out without reason. Noticed battery was down to one bar, so I charged it. Now it won't boot past the spinning double arrow so 99% of all the guides out there do not work. My device is not rooted. I have no idea what version of the software is running on it, but I have not updated it in about 10 years when I did so because it completely froze up.
I followed st3v3's guide here:
and slowly started slogging my way through since as it always is with computers something is always different or doesn't work as described. <bangs head on desk> . Accordingly here are the steps I followed up to where I am stuck:

1) Downloaded and installed putty on my windows 10 laptop.

2) I did "Copy the '/OS firmware' directory from rupor-rescue.7z into the
root of a newly formatted (FAT-32 formatted, 4GB or larger) microSD-card (which had been in my ereader so I know it reads it.) Switch
off the prs-t1, put the card into its slot, then switch it on while
keeping the 'home' and 'menu' buttons pressed until the 'opening
book' progress bar reaches 100%. This brings up the recovery
console, and also allows usb access to the prs-t1's internal storage."
That worked great and I even found the necessary rupor-rescue.7z it still be available for download. (That's another problem with trying different help guides for this problem - many files referenced don't exist so you keep going down dead ends)

At this point my experience deviates from the guide. When I plug in the USB cable my laptop recognizes the device (as a side note, a week ago I copied ebooks to the device so I know all the necessary drivers are theoretically on the laptop) and but not the storage and asks to format it. I definitely cancel that.
Next I try to install drivers. So I go to device manager and see an exclamation point under Device Manager > Other Devices > RNDIS. Tried to install a driver without success. Loaded up putty and tried various serial com ports without success. On a hunch I wen back to Device Manager > Ports (COM & LPT). See if it shows what Com port is being used. Indeed I lucked out. It shows in parentheses after "USB Serial Device (COM8).

2) So I fire up putty, put it in serial mode, change port to com8 and am thrilled that it starts up!

3) Typed "root" to log in as root admin.
localhost login: root
Remount SD card with command:
[root (ttyGS0)]# mount -o remount,rw /dev/mmcblk0p1 /initrd/mnt/sd
Attempted to make a backup image of the internal storage on the sd-card:
[root (ttyGS0)]# dd if=/dev/mmcblk2 of=/initrd/mnt/sd/mmcblk2.img
but that failed:
dd: /dev/mmcblk2: Input/output error

4) I figure since I don't need to downgrade my version since I am 99.99% sure that my installed version is older than, a backup is not crucial for me. What's the worst that could happen, I brick it? It's already completely unresponsive so I plow on.

5) Next I want to run the commands necessary to fix errors.
[root (ttyGS0)]# busybox chmod +x e2fsck
But I get an error.
chmod: e2fsck: No such file or directory

So what am I missing here? Was there some crucial step that I missed? Unfortunately I don't know linux so I have no option but to copy/paste commands verbatim and hope they work. If they don't, I don't have any recourse. It seems to me that either the e2fsck or chmod or busybox command does not work. Are these not included with the "rupor-rescue.7z" file that a copied to the SD, or is my syntax wrong because putty changed, or what would cause these errors?

Since I am floundering about as much as someone trying to navigate in China by pointing at phrases copied from the internet, any help in deciphering what else I can try, why commands don't work, etc are greatly appreciated.

The other option, which would be my preferred method, would be to simply completely format and then replace all of the data on the ereader with restore software....but since I only have access via putty I would need to do so via SD card. Unfortunately every single guide I have found for that assumes that one has access directly to the storage on the ereader via a USB connection. If there is a simple way to and simple commands to format the ereader partitions, copy the restore files over to the proper ereader partition, and hit reboot, then this would be infinitely better than trying to repair errors in the existing file and hope against hope that after that thing work.
gandalfthewite is offline   Reply With Quote