View Single Post
Old 08-19-2015, 10:09 PM   #16
Junior Member
taug began at the beginning.
Posts: 2
Karma: 10
Join Date: Aug 2008
Device: sony 505, PRS-T1
forkpower - thank you for posting this solution. It worked for me.

My PRS-T1 had the 1.0.07 firmware. It wasn't rooted or modded in any way but started exhibiting the same problems as described by everyone here. I tried doing recoveries and restores but nothing made a difference. Using forkpower's method, I ended up putting 1.0.05 on my T1 and now the USB and Wifi work fine. I think I'll leave it at 1.0.05 since I'm not using the Kobo store.

I have a Windows 7 computer here but I was able to boot up Slax on a flash drive. Slax is so small that it didn't come with a hex editor but there was a downloadable module that added that. For me, the trick was determining which device file was the PRS-T1. On my system, it ended up being:


as it was the one with the 10 partitions:


I feel like the procedure here would be useful to add to the "PRST1 Rooting and Tweaks" wiki for mobileread. Are there any moderators that can help with that?
taug is offline   Reply With Quote