View Single Post
Old 04-08-2018, 03:29 PM   #27
misterr0b0t
Junior Member
misterr0b0t began at the beginning.
 
Posts: 4
Karma: 10
Join Date: Apr 2018
Device: Kindle Paperwhite
Quote:
Originally Posted by spinky View Post
First: THANK YOU SO MUCH YOU ARE A LIFESAVER!!! I had a near catastrophe today where my Kindle for PC refused to download a book I bought this morning and desperately want to read. (I hate when people only sell their books on Amazon. )

Second: I was able to successfully import and convert a book from the Android app.

First I had to locate the kfx file on my phone, which took a while. (The files were in /storage/emulated/0/Android/data/com.amazon.kindle/files but I don't know if that's universal I found it doing a search for .kfx.)

Then I zipped the whole directory labelled with the B0* book ID.

I emailed it to myself (because it beat messing around trying to set up mtpfs crap or get adb to work so I could transfer files). I also sent along with the .ticr file and the one that was just a string of numbers and characters from the files directory. (I don't know if those two files are necessary, but I was recreating the directory structure.)

On my desktop, where I have Calibre, I created a "KFX" directory. I dropped the .ticr file and the other in the folder root and then extracted the zipped B0* folder.

I followed your setup directions on the desktop, used the extracted B0* directory as the import source, and bam, it worked like a charm. I'll be reading my shiny no-longer-kfx book on my aging Nook tonight. Thanks!
I tried your method, but it didn't seem to work. I was able to zip the entire B0* directory, created a "KFX" directory on my desktop, then extracted the zipped B0* folder. But when I tried adding in the directory to Calibre, it began adding all the files in the extracted folder (45 total). I don't know if it matters, but I either couldn't find the .ticr file and the one that was a string of numbers and characters, or they weren't there.

Any ideas of what I am doing wrong?
misterr0b0t is offline   Reply With Quote