View Single Post
Old 03-05-2019, 07:48 PM   #44
embryo
Evangelist
embryo will blow your mind, man!embryo will blow your mind, man!embryo will blow your mind, man!embryo will blow your mind, man!embryo will blow your mind, man!embryo will blow your mind, man!embryo will blow your mind, man!embryo will blow your mind, man!embryo will blow your mind, man!embryo will blow your mind, man!embryo will blow your mind, man!
 
embryo's Avatar
 
Posts: 462
Karma: 57018
Join Date: Aug 2013
Device: Kobo Glo
Quote:
Originally Posted by Frenzie View Post
I was trying to install Pyside in a Lubuntu 16.04 VM and I couldn't.
I read somewhere that it was because of "Pyside could not get installed in Python after version 3.4".

I setup another VM (Xubuntu) updated to 18.04 and succeed in installing everything.... and got to the same error as yours
It has to do with the pyside's resource creator (it creates code for Python2).

Bypassed it by not using it and loading the images from the original files.
Got an error from future.moves.urllib.request.URLError, bypassed it ... got another from ...

I'll get there some time in the future
Quote:
But PySide2/Qt5 would be preferable in the long run in any case.
PySide2 needs Python3, and that is a problem for many other libraries or for backwards compatibility (I do have a system with XP on it, that can run all my apps)
I'm a Luddite I know, but I don't want to throw away machines that work fine, just so I can wait more time for loading the newer super duper Word or Photoshop
embryo is offline   Reply With Quote