View Single Post
Old 02-06-2019, 11:21 PM   #33
davidfor
Grand Sorcerer
davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.
 
Posts: 16,217
Karma: 26150342
Join Date: Jul 2011
Location: Sydney, Australia
Device: Kobo:Touch,Glo,Aura H2O,Glo HD,Aura ONE,Clara HD,Forma;tolino epos
Quote:
Originally Posted by maximus83 View Post
I was testing one book, wiht multiple annotations. The other annotations were NOT there in preview when I attached the kobo with the book still open. It only showed the latest one I had entered (I repeated that 2x). It struck me maybe I should exit the book, I did that, and then it picks up all the annotations.

ETA: I just added more notes, exited and restarted calibre, and imported again. This time, I did NOT exit the book but left the book open at the position I had added the latest note. Only the last note was imported. Maybe be kind of an edge case that nobody ever does (leaving a book open, connecting, and then importing). I keep testing, and getting variable results, not sure what's causing the difference and sometimes full import, sometimes not.
OK, that's weird and shouldn't be happening. Having the book opened when you connect to the PC shouldn't affect things. The annotations are stored in the database as soon as they are created and the book gets closed properly.

Can you run calibre in debug mode and post the log? Hopefully there is something obvious in that tells me what is wrong. But, I might also need the database.

To run in debug mode, right-click the preferences button in calibre and select the "Restart in debug mode" option. Calibre will restart and should display a message about the debug log. Then connect the device and run the annotations fetch. When you get the the import dialog, you can stop. Then close calibre and the debug log should be displayed. Post the contents or PM it to me.
davidfor is offline   Reply With Quote