View Single Post
Old 01-12-2020, 06:12 AM   #1
Juzzybear
Junior Member
Juzzybear began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Jan 2020
Device: Kindle
Unhappy Issues with Library after folder move

Hi, first time here, so unsure if this is the right location to post this.

I recently got a NAS device and moved all my books to the device and pointed Calibre at it.

The device is accessible from my computer with full privileges and I can read/write/create, etc. I've even started Calibre with Admin privileges.

However, I am getting an issue when I perform any action on the new database. For example, if I try and add a new book, i get this error (see below). It actually does add the book, but this issue keeps coming up. If I convert, it does the convert, but then I get the same error popping up.

I've tried library maintenance and fixed any issues known, but no joy.

Can anyone help with this?

Thanks, J

Quote:
calibre, version 4.8.0
ERROR: Errors while adding: Failed to add any books, click "Show details" for more information


----------------------------------------------------------------------
Failed to add the book: Stop Motion Magazine 02 Octobe
C:\Users\jhjsh\Downloads\Stop Motion Magazine 02_ Octobe - John Ikuma.pdf
With error:
Traceback (most recent call last):
File "site-packages\calibre\gui2\add.py", line 414, in add_book
File "site-packages\calibre\db\legacy.py", line 225, in create_book_entry
File "site-packages\calibre\db\cache.py", line 62, in call_func_with_lock
File "site-packages\calibre\db\cache.py", line 1590, in create_book_entry
File "site-packages\calibre\db\cache.py", line 1310, in set_metadata
File "site-packages\calibre\db\cache.py", line 1136, in update_path
File "site-packages\calibre\db\backend.py", line 1606, in update_path
File "site-packages\calibre\db\tables.py", line 137, in set_path
File "site-packages\calibre\db\backend.py", line 874, in execute
File "c:\t\t\apsw-nhrdandw\src\cursor.c", line 236, in resetcursor
CantOpenError: CantOpenError: unable to open database file
Juzzybear is offline   Reply With Quote