View Single Post
Old 01-28-2017, 03:43 PM   #1
arboon began at the beginning.
Posts: 11
Karma: 10
Join Date: Jan 2017
Location: Amsterdam
Device: Onyx Boox C67ML
Angry Boox C67ML stuck in bootloop after update to 1.8.0

Dear all,
recently I bought a C67ML second hand. In good shape and working fine. I though to update it to 1.8.0 to improve pdf reading (1.8.0. includes neoreader, the version I had did not) and to have Google Play.
So, from the Onyx website I downloaded the file, installed in the root folder, and updated it. Which went fine, until it rebooted and go stuck in a bootloop: the forever screen with starting up.
Of course I tried a reset, recovery and the whole shabang with updating from sd card, even tried 1.7.5 version from the same Onyx site. I also tried factory reset and wiping data/cache.
Does anybody had this issue? I did read someone had a comparable issue and had to ship it to China to get it fixed. No way I am going to do that. I am pretty angry that the official firmware update caused my machine to get sort of bricked. It is useless now.
If anybody has a solution (flash new ROM?) I would love to hear it.

Last edited by arboon; 01-28-2017 at 03:48 PM.
arboon is offline   Reply With Quote