View Single Post
Old 09-17-2011, 06:10 PM   #7
CdnBloodlust doesn't litterCdnBloodlust doesn't litter
Posts: 18
Karma: 120
Join Date: Sep 2011
Location: Edmonton, AB
Device: Kobo Touch
Edit: Fixed the problem by moving the code from rcS2 to rcS. Telnet works now. I'll leave my original post below.


Kobo Touch

Thank you, great work. Been using Linux for 5+ years, but I'm not that great. I've tried your tutorial for getting FTP and telnet working. FTP works great but not telnet.

Edited file contents:

mkdir -p /dev/pts
mount -t devpts devpts /dev/pts
# <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
# ftp	stream	tcp	nowait	root	/usr/sbin/tcpd		in.ftpd
# telnet	stream	tcp	nowait	root	/usr/sbin/telnetd	telnetd -l /bin/login
21 stream tcp nowait root /bin/busybox ftpd -w -S  /
23 stream tcp nowait root /bin/busybox telnetd -i
# This is run first except when booting in single-user mode.
::respawn:/sbin/getty -L ttymxc0 115200 vt100
::shutdown:/bin/umount -a -r
::respawn:/usr/sbin/inetd -f /etc/inetd.conf

Using the I first copied the files I was gonna edit just to be safe. There's some comments in inetd.conf, but I just used your lines for those.

So ftp works great but no telnet ...

Output of ftp and telnet where just ftp works:

% ftp
Connected to
220 Operation successful
Name ( root
230 Operation successful
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
200 Operation successful
150 Directory listing
total 171
drwxr-xr-x 2 root root 3072 Sep 17 13:33 bin
drwxrwxrwt 6 root root 2440 Sep 17 15:06 dev
drwxr-xr-x 4 root root 1024 Sep 17 13:33 drivers
drwxr-xr-x 15 1000 1000 1024 Sep 17 14:10 etc
-rw-r--r-- 1 root root 143878 Jun 28 08:01 fs.md5sum
drwxr-xr-x 9 root root 5120 Sep 17 13:19 lib
drwxr-xr-x 6 root root 1024 Sep 17 13:20 libexec
lrwxrwxrwx 1 root root 11 Sep 17 13:19 linuxrc -> bin/busybox
drwx------ 2 root root 12288 Sep 17 13:19 lost+found
drwxr-xr-x 5 root root 1024 Jul 4 15:54 mnt
dr-xr-xr-x 58 root root 0 Dec 31 1969 proc
drwxr-xr-x 3 root root 1024 Sep 17 13:20 root
drwxr-xr-x 2 root root 3072 Sep 17 13:20 sbin
drwxr-xr-x 12 root root 0 Sep 17 14:41 sys
drwxrwxrwt 3 root root 100 Sep 17 14:42 tmp
drwxr-xr-x 7 root root 1024 May 30 20:46 usr
drwxr-xr-x 5 root root 1024 Sep 17 13:20 var
226 Operation successful
ftp> 221 Operation successful
% telnet
Connected to
Escape character is '^]'.
Connection closed by foreign host.

So it seems to be connecting then closing right away. I'm gonna try some things to get it working but I'm not great with telnet so if anyone has any help that would be great.

Note busybox seems to be changed in the latest update KoboRoot.tgz.
Note /dev/pty doesn't exist. only block char input are in /dev. Is rcS2 not getting executed? Gonna try putting the code from rcS2 in rcS.

Thank you very much, great work. <3

Last edited by CdnBloodlust; 09-17-2011 at 11:19 PM.
CdnBloodlust is offline   Reply With Quote