View Single Post
Old 11-15-2011, 10:49 AM   #12
theducks
Well trained by Cats
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 22,282
Karma: 22142024
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: K4NT, Galaxy Tab A
Quote:
Originally Posted by liongabriel View Post
I've read a few of these posts looking and couldn't find a solution, i apologize if i missed it. I'm new to making ebooks, although I know HTML and CSS.

I am working on a client's eBook in ePub format and using Sigil, it seems to work on the Nook, and other browsers but on the iPhone in iBooks, I'm missing chapter 9 in the TOC. every other chapter is there, and I've checked the code and re-written it... i can't figure out why it's not showing up.

I saw it's touched on in this thread, but I'm using version: 0.4.2 on a macbook pro, and no luck with ch9.

here's my code on the headers:

<h1 class="story sigilNotInTOC" id="Chapter-Nine.html" xml:lang="en-US" xmlns:xml="http://www.w3.org/XML/1998/namespace"></h1>
<hr class="sigilChapterBreak" />

<div style="text-align: center;">
<h1 class="title_one" id="heading_id_2">CHAPTER NINE<br /></h1>
</div>

<div style="text-align: center;">
<h2 class="Subheader" id="heading_id_3">He Didnít Accept It Then, He Wonít Accept It Now<br /></h2>
<div>

I'd really appreciate help, I imagine this is an easy fix.

Thanks in advance!

Gabriel
Somehow you removed the Tick mark in the TOC editor. (NB when you do that, Sigil adds a Flag (in Red, above) so the next phase does not ever use that H tag as a TOC.)
2 ways to fix.
1) remove that phrase
2) Open the TOC editor, UN-tic the "TOC items Only" box, now you can see both the Included and Hidden items.

Want to see where a particular hidden item is? Tick it, Save the TOC edit.
Now it shows in the Book Browser list.
Double-click that line item. Presto! it (the page, at least) appears in the Edit window.
theducks is offline   Reply With Quote