View Single Post
Old 11-04-2017, 11:36 PM   #425
HopScotch
Junior Member
HopScotch began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Nov 2017
Device: kindle
Hi Ephemerality,
I downloaded "xray-builder-gui-v2.0.23b.zip" but I get the following error when I try to run a search on GoodReads (using the button that has the magnifying glass on it)

Quote:
An error occurred while searching: Could not load file or assembly 'HtmlAgilityPack, Version=1.6.2.0, Culture=neutral, PublicKeyToken=bd319b19eaf3b43a' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
at XRayBuilderGUI.DataSources.Goodreads.<SearchBook>d __7.MoveNext()

I checked the version of HtmlAgilityPack and it's 1.4.9.5, (not the 1.6.2.0 that it says it requires), so I went online and found 1.6.2.0 and ran it with that and it worked! Buuuut then when I hit the checkbox I get the error

Quote:
Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately.

System.IO.FileLoadException: Could not load file or assembly 'System.Data.SQLite, Version=1.0.105.2, Culture=neutral, PublicKeyToken=db937bc2d44ff139' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
File name: 'System.Data.SQLite, Version=1.0.105.2, Culture=neutral, PublicKeyToken=db937bc2d44ff139'
at XRayBuilderGUI.frmMain.<btnBuild_Run>d__22.MoveNex t()
... I see the version of "System.Data.SQLite.dll" X-Ray builder has in its main folder is 2.023.0 (not the 1.0.105.2 that the program says it's looking for).


... So why does my version of X-Ray Builder that I downloaded today have the wrong files, and is there a workaround or maybe a quick fix on your end?

Last edited by HopScotch; 11-04-2017 at 11:38 PM.
HopScotch is offline   Reply With Quote