View Single Post
Old 10-14-2020, 03:25 PM   #1412
Macondo began at the beginning.
Posts: 12
Karma: 10
Join Date: Jan 2017
Device: kindle paperwhite 3
Originally Posted by davidfor View Post
The error with the help should be fixed in the beta I just uploaded in response to @Terry Brown's report.

The other error is a problem loading the certificates on your computer. I can't tell if they are out of date, or something else. In the past, a lot of the certificate problems are solved by browsing to the site using Microsofts browser. This can update the central store which is what the plugin is using. The other browsers do not do this. This might solve the problem for you.

A search for the error does suggest you might have a certificate that is triggering the problem. But, it also suggests the way this is being handled in the code isn't the best. I'll look at it to try and work out how to solve this. But, try the browser to see if that fixes it.
Certificates are valid (not out of date) and they are in my computer.
Tried wit IE and Edge browsing goodreads, but this didn't helped.
If I find solution somehow I'll post it here. For now there is only hope.

And yes. error with help is fixed. Thank you.

Update 01:
just one more consideration for my previous post and problem.
I am not sure that problem is in my certificate base, because just now, on same computer
I started
calibre portable version 4 which works just fine, and I can link books with gr
(plugins: goodreads 1.4.0 and goodreads_sync 1.14.3),

and started after that
calibre portable version 5 which give me error for authentication with goodreads.
(plugins: goodreads 1.5.1 and goodreads_sync 1.14.7)

I started thinking if my certificate base is corrupted, than calibre portable 4 would not working too?

So, is there a chance to get earlier versions (between 1.4.0 and 1.5.1 for goodreads, and between 1.14.3 and 1.14.7 for goodreads_sync) of those two plugins for calibre portable 5 so I could check if some of them working on my computer.

Update 02:
just checked something, problem is not in plugins, problem is in calibre 5 (from 5.0.1-5.2.0). So, I copied my calibre portable 4 on another location and installed all version calibre portable 5 over that installation and get same error, then I reinstalled calibre portable 4 over that installation (with plugins: goodreads 1.5.1 and goodreads_sync 1.14.7)and everything working fine. So, error should be searching in calibre portable 5.

Last edited by Macondo; 10-15-2020 at 12:42 PM. Reason: added text from next post, which should be deleted
Macondo is offline   Reply With Quote