View Single Post
Old 04-07-2009, 07:50 PM   #9
jantzde began at the beginning.
Posts: 16
Karma: 10
Join Date: Apr 2009
Device: PRS-505
Originally Posted by igorsk View Post
Use this one, not the "Russify" package:
Okay.....I ran the Universal Flasher and got the menu and selected 7. That seemed to execute and then gave the meassage that it didn't update sucessfully.

I then ran the Sony Updater and when prompted plugged the 505 to my PC. The screen showed "Reader....updating firmware now...".

and that's as far as I got. It never rebooted and it never reached the end of "updating". Now I can't even shut the unit off and on the screen now it says..."Firmware update did not complete successfully, please try again"

I've tried "again" 3 times and it still doesn't reboot during the process and it won't power down.

I tried doing a reset and that didn't phase it either. It's STILL on.

Next ideas? Please?? (and thanks to all of you who are responding and offering suggestions)
jantzde is offline   Reply With Quote