View Single Post
Old 02-06-2020, 05:50 AM   #23
kiki34420
Member
kiki34420 began at the beginning.
 
Posts: 11
Karma: 10
Join Date: Jan 2020
Device: vivlio
Bonjour,
malheureusement ça ne fonctionne toujours pas !
C'est vraiment bizarre ce truc.
j'ai toujours le message le même message
voici le détail :
"calibre, version 4.9.0
ERREUR : Exception non gérée: <b>InvalidPlugin</b>:The plugin in u'/Users/christianbureau/Downloads/babelio_notes_mac.zip' is invalid. It does not contain a top-level __init__.py file

calibre 4.9 embedded-python: True is64bit: True
Darwin-19.0.0-x86_64-i386-64bit Darwin ('64bit', '')
('Darwin', '19.0.0', 'Darwin Kernel Version 19.0.0: Thu Oct 17 16:17:15 PDT 2019; root:xnu-6153.41.3~29/RELEASE_X86_64')
Python 2.7.16
OSX: ('10.15.1', ('', '', ''), 'x86_64')
Interface language: fr
Successfully initialized third party plugins: Resize Cover (1, 0, 2) && Find Duplicates (1, 6, 3)
Traceback (most recent call last):
File "site-packages/calibre/gui2/preferences/plugins.py", line 319, in add_plugin
File "site-packages/calibre/customize/ui.py", line 472, in add_plugin
File "site-packages/calibre/customize/ui.py", line 61, in load_plugin
File "site-packages/calibre/customize/zipplugin.py", line 194, in load
File "site-packages/calibre/customize/zipplugin.py", line 292, in _locate_code
InvalidPlugin: The plugin in u'/Users/christianbureau/Downloads/babelio_notes_mac.zip' is invalid. It does not contain a top-level __init__.py file

si je dézippe manuellement j'ai les fichiers suivants :
worker.py
ui.py
un dossier images
_init_py
plugin-import-nam-babelio_notes.txt

une question peut-être stupide : n'y a t-il pas moyen de placer ces fichiers directement au bon endroit sans passer par l'installer ?
merci en tout cas pour votre aide car j'aimerais vraiment pouvoir intégrer votre extension dans ma base de donnée. j'ai commencé à lire la doc sur la réalisation d'extension mais c'est trop ardu pour moi bien qu'ayant quelques vagues notions de programmation.
kiki34420 is offline   Reply With Quote