View Single Post
Old 07-07-2010, 01:35 AM   #1
Bodman456
Junior Member
Bodman456 began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Jul 2010
Device: iPhone 3G with Stanza/iBooks
Exclamation Calibre Content Server error in Ubuntu 10.10

Hi all,

Today I went to transfer my newspapers into Stanza through Calibre. My iPhone couldn't find the content server automatically. No big deal, I thought, so I went and tried entering the hostname as a catalogue, but that wouldn't work either. Then I went into Calibre's preferences, I noticed the server wasn't started. So I hit "Start Server", but it just came up with this error:
Code:
ERROR: ERROR: Unhandled exception: <b>ImportError</b>:No module named routes

Traceback (most recent call last):
  File "/usr/lib/calibre/calibre/gui2/dialogs/config/__init__.py", line 776, in start_server
    from calibre.library.server.main import start_threaded_server
  File "/usr/lib/calibre/calibre/library/server/main.py", line 12, in <module>
    from calibre.library.server.base import LibraryServer
  File "/usr/lib/calibre/calibre/library/server/base.py", line 23, in <module>
    from calibre.library.server.opds import OPDSServer
  File "/usr/lib/calibre/calibre/library/server/opds.py", line 15, in <module>
    import routes
ImportError: No module named routes
Does anyone know how to fix this? I am running Calibre 0.7.1 under Ubuntu 10.10 Maverick Meerkat. This is the first time I have tried transferring books through Calibre, and I have already checked my WiFi connections.
Bodman456 is offline   Reply With Quote