Thread: Firmware Update Kindle bricked after 2.5 update
View Single Post
Old 06-30-2010, 12:27 AM   #1
Junior Member
MePerson began at the beginning.
Posts: 1
Karma: 10
Join Date: Jun 2010
Device: Amazon Kindle 2
Unhappy Kindle bricked after 2.5 update

I have a Kindle 2 International (serial starting with B003) that had the 2.3 firmware on it. When the 2.5 update was released to the public and available for download on the Amazon website, I downloaded the update to my Kindle manually for the update.

In the past, I've successfully installed and subsequently uninstalled several screensaver/font hacks, so I'm fairly sure I did it correctly.

Noticing the battery was low, I plugged it into the Kindle wall adapter; the light lit normally and the charge indicator appeared. I clicked Settings > Update. The Kindle proceeded with the update without me observing it. After a few minutes, I glanced over to see the progress bar chugging along slowly. About 15 minutes later or so, I checked on the progress again, and discovered that it had apparently finished and was now on the "Your Kindle is starting up. / This can take a minute."

Then it never exited that screen. I also noticed that the charge light had gone out, even though it was still plugged in.

I tried holding down the power button for 15 seconds to reset it... nothing. Holding down "Home" to enter Recovery Mode... nothing. Plugging into computer... didn't show up.

It was, essentially, bricked.

I read somewhere that someone had a similar problem, and was able to fix it by waiting a few days to drain the battery, and then charging it completely.

After a few days I tried plugging it in, and sure enough the charge light lit amber. It was short-lived, however, as it went out after a few minutes. Reset still didn't work.

It's been a couple weeks since I tried the update.

Anyone have any ideas before calling Amazon?
MePerson is offline   Reply With Quote