View Single Post
Old 06-27-2010, 02:35 PM   #32
Groen began at the beginning.
Groen's Avatar
Posts: 55
Karma: 44
Join Date: Mar 2009
Location: The Netherlands
Device: iRex DR1000S
Originally Posted by pauli View Post
can you check if the dr.ini file in the X:\system folder on your DR1000 shows something "strange"? There are entries for different filetypes. Mine doesn't show an entry for *.mht file but it does contain this line:
Well, here is something weird. I just started again with a cleanly formatted SD-card. Put FW 2.0RC2 on it. Created a directory "Personal Documents" and put some test files in it: pdf, epub, txt, html, and mht.

Then I rebooted the DR1000. It installed FW 2.0RC.

I then tried to open the test files. PDF and txt opened. Html and ePub showed in the list, but refused to open (the wait dialog showed shortly, and disappeared again). Mht simply didn't show up at all.

I then reconnected to the PC again. This is what dr.ini contains:


/apps/er/sys/global/list_languages=Deutsch;English (UK);English (US);Espa˝ol;Franšais;Italiano;Nederlands;Ελληνικά;
Only file type mentioned is epub.

I checked the directory, all files were still there. The DR had also created a metadata.db file. I deleted the metadata.db, hoping the ePub file would afterwards show up (I had this problem earlier this week. Deleting the metadata.db solved the problem then). I also renamed dr.ini to dr.ini.old.

I disconnected from the PC. However, no change at all. Even the ePub didn't work after deleting the metadata.db.

Originally Posted by pauli View Post
2) rename the dr.ini file to dr.old.ini , reboot, your DR1000 will make a new dr.ini file. You will loose your personal settings (lock sensors, language etc) , but if it doesn't help and make the *.mht files visible you can always return to your original settings
After deleting dr.ini, disconnecting the DR, the files (ePub, html, and mht), could still not be opened. Connecting the DR to the PC again showed a dr.ini that has the same content as dr.ini.old.

Originally Posted by pauli View Post
two more things you could try:
1) change the file extension to *.mhtml
Finally, changing the file extension to mhtml. Disconnected again. The mthml file does still not show up.

I also don't understand why earlier this week, deleting metadata.db did make my DR to suddenly open my ePubs, and now it does not seem to make any difference.

EDIT: After restarting the DR, the ePub file opens fine. mht and html still behave in the same way though (the former not showing up, the latter refusing to open).

Last edited by Groen; 06-27-2010 at 02:44 PM. Reason: Added an aditional paragraph.
Groen is offline   Reply With Quote