View Single Post
Old 06-23-2010, 11:25 AM   #1
Junior Member
Nirf began at the beginning.
Posts: 5
Karma: 10
Join Date: Aug 2008
Device: PRS-505
Converting PDF to HTML

Hello all,

while trying to convert PDF format to LRF format it goes through HTML as an intermediary (apparently), and it hangs on this phase. I'm running ubuntu 10.04, I tried both installing from repo and then trying the latest version by downloading off the website. I used the console command ebook-convert, and after a while I hit control C to end it. Here's what it looks like.

ebook-convert hello.pdf hello.lrf
1% Converting input to HTML...
InputFormatPlugin: PDF Input running
on /home/nir/Documents/Calibre Library/Malcolm Gladwell/Outliers_ The Story of Success (Little, Brown & Co; 2008) (3)/hello.pdf
^CTraceback (most recent call last):
File "/tmp/", line 48, in <module>
File "/home/kovid/build/calibre/src/calibre/ebooks/conversion/", line 254, in main
File "/home/kovid/build/calibre/src/calibre/ebooks/conversion/", line 815, in run
File "/home/kovid/build/calibre/src/calibre/customize/", line 211, in __call__
File "/home/kovid/build/calibre/src/calibre/ebooks/pdf/", line 50, in convert
File "/home/kovid/build/calibre/src/calibre/ebooks/pdf/", line 61, in pdftohtml
File "/usr/lib64/python2.6/", line 1157, in wait
pid, sts = os.waitpid(, os.WNOHANG)

Any suggestions with this? As I said, I tried both the repo install and then the direct download install (after removing the repo) and had the same problem both times. I don't know where to go from here because it seems to be getting stuck in a generic python file, and its the correct version of python... Help appreciated!
Nirf is offline   Reply With Quote