View Single Post
Old 06-16-2010, 11:24 PM   #1
Junior Member
htbyron began at the beginning.
Posts: 2
Karma: 10
Join Date: Jun 2010
Device: Nook
Question Calibre won't open after install -- ERROR: Bad database location

I have tried multiple times now to install Calibre on my desktop computer (Win XP Home SP3). I tried both versions 0.7.2 and 0.7.1, fully uninstalling each time before trying to reinstall from a clean download of the installer. Every time I get the following error:

ERROR: Bad database location

Here are the details:
ERROR: Bad database location: Bad database location u'E:/My Documents/Calibre Library'. calibre will now quit.

Traceback (most recent call last):
File "site-packages\calibre\gui2\", line 183, in initialize_db_stage2
File "site-packages\calibre\library\", line 128, in __init__
File "site-packages\calibre\library\", line 20, in __init__
File "site-packages\calibre\library\", line 50, in upgrade_version_2
File "site-packages\calibre\library\", line 184, in run
DatabaseException: trigger fkc_delete_on_authors already exists
RemoteTraceback (most recent call last):
File "site-packages\calibre\library\", line 148, in run
OperationalError: trigger fkc_delete_on_authors already exists
It looks like the Calibre installer is inserting the letter "u" before the pathname, but maybe that's just how the error code generates.

I have admin rights on my system, I am the only user. I am about to give up on this software, but it has gotten such good reviews from others.

Has anyone else had this problem? Any suggestions?
htbyron is offline   Reply With Quote