View Single Post
Old 05-12-2010, 03:54 AM   #6
Junior Member
akosimike began at the beginning.
Posts: 5
Karma: 10
Join Date: May 2010
Device: iPhone
Originally Posted by dwanthny View Post
The remove spacing only works on paragraphs or divisions. When you run into a book that it doesn't work on it is usually because the line breaks are hardcoded in the html using <br/> instead of </p><p> paragraph html.

The only way to correct this is by manually editing the html. You can do this by running the conversion with a directory specified in the Debug area of Calibre. Once the (failed) conversion is complete look in the directory you specified and you will find the resultant html before conversion.

I have had easy fixes and books that I decided weren't worth it once I viewed the source. The easy fixes were simply replacing <br/> with <br/><br/> then using a find and replace to substitute </p><p> with every set of <br/><br/> in the document. This changes the line breaks to paragraphs. I use notepad++ for this.

Then I hand edit out the large groups of </p><p> before chapters etc... Drag the new html to Calibre and convert.

Each html document is different, Good Luck.
Hmm just to add some info, when I had this problem before I tried stanza and it worked fine, so maybe the problem was with calibre...? With stanza I had to transfer 1 book at a time which sucked and now stanza is having issues with bonjour so I moved back to calibre but there is still this issue...

Well thanks for the help, heres to hoping amazon lets the stanza group continue to update stanza ... yeah prolly not gonna happen lol.
akosimike is offline   Reply With Quote