View Single Post
Old 03-05-2010, 06:14 PM   #1
Junior Member
ksburgess began at the beginning.
Posts: 7
Karma: 10
Join Date: Mar 2010
Device: netbook
Unhappy Calibre Binary Install Upgrade Failed Today

When I opened Calibre today I received notification that an upgrade is available.

I have always used the binary install from terminal to upgrade Calibre and it has always gone flawlessly.

That failed today, which totally blew up my Calibre install. Here's the output I got - it looks like there may be a corrupt file?

username@homedirectory:~$ sudo python -c "import urllib2; exec urllib2.urlopen('').read(); main()"
Enter the installation directory for calibre [/opt]: /opt
Will download and install calibre-0.6.44-i686.tar.bz2
                    Downloading calibre-0.6.44-i686.tar.bz2                     
590% [=============================================================================================================================================================================================================================================================================================================================================================================================================================]
                                                                                Extracting files to /opt/calibre ...
Extracting application files...
bzip2: (stdin) is not a bzip2 file.
tar: Child returned status 2
tar: Exiting with failure status due to previous errors
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "<string>", line 207, in main
  File "<string>", line 182, in extract_tarball
  File "/usr/lib/python2.6/", line 488, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['tar', 'xjf', '/tmp/tmpb2S1ru', '-C', '/opt/calibre']' returned non-zero exit status 2

username@homedirectory:~$ calibre
The program 'calibre' is currently not installed.  You can install it by typing:
sudo apt-get install calibre
calibre: command not found
After getting this I tried to reinstall Calibre using apt-get, which failed. I then went and completely removed Calibre via my package manager. Then I re-installed via the package manager, using my distro's repositories (Ubuntu Netbook Remix 9.10).

This worked - I now have Calibre funtional again. However, it's not the latest version and I would like the latest version. Is there an issue with the binary install or have I done something wrong? I did double and triple check to make sure I cut/pasted the binary command correctly.


Last edited by ksburgess; 03-05-2010 at 06:17 PM. Reason: forgot to give distro
ksburgess is offline   Reply With Quote