View Single Post
Old 02-21-2010, 10:25 PM   #4
Junior Member
Deucalion began at the beginning.
Posts: 5
Karma: 10
Join Date: Feb 2010
Device: iTouch/Stanza
Hello all. New member here. I had to join the forum because I've been struggling with this "Port #### not free on ''" problem all day. I'm out of ideas, and have tried everything suggested in this forum.

I'm using Vista Ultimate SP2 and Calibre v6.42. Cannot get the content server to connect to any port. I tried over 3 dozen combinations, all verified by netstat as not being used. Tried disabling the Windows firewall completely. Even went into the 'Windows Firewall with Advanced Security' and disabling the firewalls on the domain profile and public profile. I went so far as to uninstall AVG and made sure Windows Defender was disabled. Ran Calibre as admin and also disabled UAC. I can't think of anything else that would keep this server from connecting to a port.

I installed Calibre on my XP machine and the content server worked instantly so it's fairly ovbious the problem is with Vista. It sure seemed like a firewall issue to me.

I was finally able to get the server working on the command-line by using port 8787. Windows created an exception in the Firewall for calibre-server.exe. For now, I simply made a simple batch file with the command...

c:\"Program Files"\Calibre2\calibre-server -p 8787

Close the command window when I'm done transferring.

BTW statiiq: You should find that if you close and reopen calibre after changing the port number it should stick next time you try connecting. At least, that's how it worked for me.
Deucalion is offline   Reply With Quote