Thread: PRS-300 Loading forever
View Single Post
Old 02-03-2010, 07:37 AM   #11
Junior Member
sickenmcsluggets began at the beginning.
sickenmcsluggets's Avatar
Posts: 7
Karma: 10
Join Date: Feb 2010
Device: Sony PRS-T1
My prs-300 just did this sort of thing last night. I had it plugged into a Pentium Ubuntu 9.10 machine, and was using Calibre 0.6.13 to transfer a book. After transferring, ejecting, and unplugging, it started fritzing out, stuck in an endless reboot and load loop, frozen. I was horrified. I use mine every day. I tried powering it down, and the reset button, I even took the whole back plate off and disconnected the battery. None of it worked.
Well, I finally connected it to my Windows XP Samsung NC20 and it all of a sudden calmly went to the home screen. Windows didn't recognize it, neither did Calibre or the Sony Software, but it was at the home screen. When I unplugged it from that, it went back to its malfunctioning behavior. I plugged it back in to the XP laptop, and went to the setting options and selected format memory. That worked, and now I have my prs-300 back! I mean, sure, all my books were deleted, but those are all on my PC anyway.
sickenmcsluggets is offline   Reply With Quote