View Single Post
Old 01-28-2010, 04:02 PM   #8
Zorz began at the beginning.
Posts: 134
Karma: 36
Join Date: Nov 2009
Device: Kindle 2i
Originally Posted by jft View Post
Nope. You misunderstood me. The IPs were just an example. The default values in the script were and and as you said the subnet has to be the same.

Now I assume you have the following configuration:

Now the steps to access the Kindle:
Now you enabled the network module, set the IP of the Kindle to and changed to default network route to the USB network interface.

Now you have to assign an IP to your pc usb interface (just think about it as an ethernet card).
On your PC:

Now your pc has IP and your Kindle

Now you can access your Kindle.

As I said in the above post you tried to telnet to your pc and not to the kindle, so you got a password prompt (root user of YOUR pc and not of the Kindle).
I followed your instructions exactly 3 times and I only get this

telnet: Unable to connect to remote host: No route to host

I also tried to change route with this

route add -host usb0

Last edited by Zorz; 01-28-2010 at 04:29 PM.
Zorz is offline   Reply With Quote