View Single Post
Old 01-17-2010, 10:51 AM   #37
Gonzo62 began at the beginning.
Posts: 17
Karma: 10
Join Date: Dec 2009
Device: iRex iLiad Book Edition
Originally Posted by Iņigo View Post
Connect to your Iliad and change to the root directory where ToolBox was installed,
export your DISPLAY settings to the IP of your Iliad ( in my case), and
run the program from the command line.
For example:
root@ereader:~$ cd /media/card/Programs/Toolbox/
root@ereader:/media/card/Programs/Toolbox$ export DISPLAY=
root@ereader:/media/card/Programs/Toolbox$ lua _files/Toolbox.lua | ./_files/xx -p
interact with the application and look at the output on the terminal if it crashes.
Now my connection is working well, I connected to my iLiad and try to run Toolbox from command line.

I exported the display settings as you described - of course with my IP :-)
It did not work with the lua command, the screen was blinking once on the iLiad and I got this warning:

: GtK-WARNING **: cannot open display:
7.027: ./_files/xx: Done

Then I tried it with "path to _files/" and it started the Toolbox on my iLiad. I clicked "File Explorer", the file explorer opened and showed the content of "/mnt/free" - as I already mentioned this is the content of the internal memory containing the folders /books and so on. I can click on one of this folders i.e. books and its opening without problems. If I'm clicking in the menu bar of file explorer on "free" in the path "/mount/free" its going on top of the folder free.

If I'm using the button "Bookmarks" in the bottom right corner to go to:
its working.

But as soon as I'm going in "Bookmarks" to "/" or clicking in the menu bar in the path to "/mount" Toolbox is closing.

So apparently the internal memory is mounted as /mnt/free including all subfolders there, the cards are mounted as /media/cf and /media/card. But its not possible to go to the root itself.

I tried again pviewer and browsed through all folders, its showing /bin /boot and so on - the complete root directory. In /mnt/free theres the internal memory mounted as in Toolbox already shown.

I have to stop testing now, some strange and pretty huge and for sure blood sucking insects are already flying around me because of all the light I turned on for seeing the iLiad screen clear

See attached file for all details about running normal, "File Explorer" and "System Information" Hope it helps you in finding out the problems.
Attached Files
File Type: txt session.txt (5.3 KB, 199 views)
Gonzo62 is offline   Reply With Quote