Thread: Opus Problem Upgrading Opus
View Single Post
Old 01-14-2010, 01:56 PM   #12
Junior Member
erwinb began at the beginning.
Posts: 1
Karma: 10
Join Date: Dec 2009
Device: Cybook Opus
solution for not recognized sd-card and update...

Originally Posted by Adri View Post
My reply to Bookeen support:

I have tried 4 different SD cards.
Two 512 Mb cards are recognized when they are inserted after the Cybook is on.
One 512 Mb card is not recognized at all.
One 4 Gb card hangs the Cybook.

I have switched the Cybook on and off numerous time with one of the cards recognised inside.

None of the cards are recognized on boot up.

All were formatted as FAT32.

Anything else I can try?
I had the same problem and worked out a solution for me. Perhaps it works for someone else, too?

I must say beforehand that my opus recognized the sd-cards only after I re-inserted them after the opus was running. Try this out before performing the following steps:

This is how it worked for me (Quoted from my reply to the Opus Hotline):
- I used an SD-Card, formatted with fat32 (SDHC 8GByte) as you described and copied the "update_kernel" file on it.
- I switched off the Cybook.
- Took out the SD-Card, but let it loosely in the slot.
- I switched on the Cybook.
- As soon as the logo appeared (after a few seconds), I pressed the center key. (As is stated for the update process.)
- Directly after pressing the center key I inserted the SD-Card (the Cybook still booting).
- The update started!
- With the new firmware the SD-Card is found by the Cybook directly after booting without having to insert it anew.
I can imagine that this might need a few tries, too. Until one hits the right moment during boot-up..
For me it worked on first try.

Since the update file is on the sd card I guess you canīt harm your Opus with this. But of course no warranty.

Good luck,

erwinb is offline   Reply With Quote