View Single Post
Old 06-12-2009, 04:05 PM   #8
Et In Arcadia Ego
angevin began at the beginning.
angevin's Avatar
Posts: 18
Karma: 10
Join Date: Dec 2007
Location: NewYork
Device: Sony prs-505
Question any ideas on this error ?

Hello again Kovid :

I fixed the podofo problem but now I ran into another problem :

................................ g++ -m64 -Wl,-O1 -Wl,-rpath,/usr/lib64/qt/lib -shared -Wl,-soname, -o pictureflow.o moc_pictureflow.o -L/usr/lib64/qt/lib -lQtGui -L/usr/lib64/qt/lib -L/usr/X11R6/lib64 -pthread -lpng -lfreetype -lgobject-2.0 -lSM -lICE -pthread -pthread -lXrender -lfontconfig -lXext -lX11 -lQtCore -lz -lm -pthread -lgthread-2.0 -lrt -lglib-2.0 -ldl -lpthread
ln -s
ln -s
ln -s
Building sbf...
/usr/bin/sip -c /usr/local/calibre-0.5.14/build/temp.linux-x86_64-2.6/calibre.plugins.pictureflow -b /usr/local/calibre-0.5.14/build/temp.linux-x86_64-2.6/calibre.plugins.pictureflow/pictureflow.sbf -I /usr/share/sip/PyQt4 -x VendorID -t WS_X11 -x PyQt_NoPrintRangeBug -t Qt_4_4_1 -g src/calibre/gui2/pictureflow/pictureflow.sip
sip: /usr/share/sip/PyQt4/QtCore/QtCoremod.sip:115: syntax error
error: command '/usr/bin/sip' failed with exit status 1
Any ideas ? I guess exit status 1 indicates a mismatch or something ? I'm not an expert at reading compilation and configuration error messages yet unfortunately for me.


Also I don't know how likely it is someone else will run into the podofo problem I did but I fixed it by configuring it with this configuration command before compilation :


Last edited by angevin; 06-12-2009 at 08:29 PM.
angevin is offline   Reply With Quote