View Single Post
Old 04-09-2009, 06:36 PM   #1
Junior Member
k8oylos began at the beginning.
Posts: 4
Karma: 10
Join Date: Apr 2009
Device: prs505
Not loading - AttributeError: /usr/bin/python: undefined symbol: FcPatternBuild

i tried to install calibre on opensuse11.1 (version found here

When i try to run it, it starts loading (cursor shows some books bumping) and then disappears after 10 seconds.
I run through console and i get

Traceback (most recent call last):
File "/usr/bin/calibre", line 8, in <module>
load_entry_point('calibre==0.5.6', 'gui_scripts', 'calibre')()
File "/usr/lib/python2.6/site-packages/", line 277, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python2.6/site-packages/", line 2180, in load_entry_point
return ep.load()
File "/usr/lib/python2.6/site-packages/", line 1913, in load
entry = __import__(self.module_name, globals(),globals(), ['__name__'])
File "/usr/lib/python2.6/site-packages/calibre/gui2/", line 27, in <module>
from calibre.gui2.dialogs.scheduler import Scheduler
File "/usr/lib/python2.6/site-packages/calibre/gui2/dialogs/", line 23, in <module>
from calibre.gui2.dialogs.user_profiles import UserProfiles
File "/usr/lib/python2.6/site-packages/calibre/gui2/dialogs/", line 10, in <module>
from calibre.gui2.dialogs.user_profiles_ui import Ui_Dialog
File "/usr/lib/python2.6/site-packages/calibre/gui2/dialogs/", line 279, in <module>
from calibre.gui2.widgets import BasicList
File "/usr/lib/python2.6/site-packages/calibre/gui2/", line 19, in <module>
from calibre.utils.fontconfig import find_font_families
File "/usr/lib/python2.6/site-packages/calibre/utils/", line 125, in <module>
lib.FcPatternBuild.restype = POINTER(FcPattern)
File "/usr/lib/python2.6/ctypes/", line 366, in __getattr__
func = self.__getitem__(name)
File "/usr/lib/python2.6/ctypes/", line 371, in __getitem__
func = self._FuncPtr((name_or_ordinal, self))
AttributeError: /usr/bin/python: undefined symbol: FcPatternBuild

I arrived here after googling the last line to this thread
i realized, as in the last post there, that i had freetype2 and not freetype installed, so i also installed that but i didn't know how to run callibre_postinstall, i just removed and reinstalled calibre, but the situation remains the same.

Also, regarding the other two questions you had in that post (if that helps)
k8oylos@linux-rovh:~> calibre-debug -c "from ctypes import util; print util.find_library('fontconfig')"
k8oylos@linux-rovh:~> readelf -a /usr/lib/ | grep FcPatternBuild
bash: readelf: command not found

Thanks in advance!
k8oylos is offline   Reply With Quote