View Single Post
Old 02-17-2009, 06:52 PM   #4
Computational Linguist
DesiLinguist doesn't litterDesiLinguist doesn't litter
Posts: 110
Karma: 100
Join Date: Feb 2009
Device: iLiad BE, iPhone, Kindle DX
I got my cf card and I tried doing the ipdf installation and I am having trouble as well. Requested the developer access package, installed fine, ran xshell which also ran fine. Then I went into the ipdf folder on the cf card and clicked on 'check which version is installed' and I get the message 'This looks like a new unrecognized version'! This is really strange. Never heard anyone getting this error before.

Here is the relevant info from iLiad's settings screen:

Software version: 2.12.1
Software build number: 21211
Kernel version: 2.4.19-rmk7-pxa2-rex1 #21210

I downloaded the all-in-one ipdf installer from the wiki page. The file was called ""

I checked what the 'check version' script was actually doing and it identifies the ipdf version by looking at the size of the file '/usr/bin/ipdf'. So, I manually checked the file size by doing a 'ls -l /usr/bin/ipdf' on mrxvt and, sure enough, the file size (82828) doesn't match any of the sizes checked in the script. The default iRex one is the closest (82804) but it still doesn't match.

Is it possible that ipdf filesize is different in v2.12.1 but the 'check version' script is still checking for the old file size (from an older version)?

Any advice/suggestions would be much appreciated!
DesiLinguist is offline   Reply With Quote